summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/xprobe')
-rw-r--r--net-analyzer/xprobe/ChangeLog5
-rw-r--r--net-analyzer/xprobe/Manifest12
-rw-r--r--net-analyzer/xprobe/files/digest-xprobe-0.2.21
-rw-r--r--net-analyzer/xprobe/xprobe-0.2.2.ebuild42
4 files changed, 49 insertions, 11 deletions
diff --git a/net-analyzer/xprobe/ChangeLog b/net-analyzer/xprobe/ChangeLog
index 0440de2acc4d..56c575e60dbe 100644
--- a/net-analyzer/xprobe/ChangeLog
+++ b/net-analyzer/xprobe/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/xprobe
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/ChangeLog,v 1.10 2005/01/31 11:40:52 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/ChangeLog,v 1.11 2005/02/17 13:45:17 radek Exp $
+
+ 17 Feb 2005; Radoslaw Stachowiak <radek@gentoo.org> xprobe-0.2.2.ebuild:
+ version bump. also end of CHOST CFLAGS problems.
31 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> xprobe-0.2.1.ebuild:
Marked stable on x86.
diff --git a/net-analyzer/xprobe/Manifest b/net-analyzer/xprobe/Manifest
index 895dc4fdffb2..018d18df183c 100644
--- a/net-analyzer/xprobe/Manifest
+++ b/net-analyzer/xprobe/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 f77837d38f082b9f9cba0335e168ba15 xprobe-0.2.2.ebuild 1083
MD5 6de3ac40279084db8a4caff42836b5d6 xprobe-0.2.1.ebuild 1216
MD5 aaa7f5bb15e8db514726c44edc25c853 xprobe-0.0.2.ebuild 759
MD5 78e19ce01f74ef8bfb7b7f8ae30d2fd3 ChangeLog 1389
@@ -8,10 +6,4 @@ MD5 ac6c11d70b477833baa876a5460fba26 metadata.xml 224
MD5 9610e3d9785f7b6eb29ab995ef30fb08 files/xprobe-0.0.2-gentoo.patch 387
MD5 2d7fd3216e38d4a4adb0d40c689bb944 files/digest-xprobe-0.0.2 63
MD5 6b20f3d65e14741fe524b8b88dbdbd73 files/digest-xprobe-0.2.1 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB/hmvEZCkKN40op4RAohXAJ4kZhKBofq3PdT68z1NT+N82E026gCfXV2R
-NHnv2+zvYRV3o8adoS3btDw=
-=wffq
------END PGP SIGNATURE-----
+MD5 deeacb60b94a028e0f05b2c33f504488 files/digest-xprobe-0.2.2 65
diff --git a/net-analyzer/xprobe/files/digest-xprobe-0.2.2 b/net-analyzer/xprobe/files/digest-xprobe-0.2.2
new file mode 100644
index 000000000000..0a879861709f
--- /dev/null
+++ b/net-analyzer/xprobe/files/digest-xprobe-0.2.2
@@ -0,0 +1 @@
+MD5 8eea1406d035827bb8bfeb0536622e1f xprobe2-0.2.2.tar.gz 521785
diff --git a/net-analyzer/xprobe/xprobe-0.2.2.ebuild b/net-analyzer/xprobe/xprobe-0.2.2.ebuild
new file mode 100644
index 000000000000..663a78dddd21
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/xprobe-0.2.2.ebuild,v 1.1 2005/02/17 13:45:17 radek Exp $
+
+inherit eutils
+
+# This is new xprobe, so called xprobe2, due to xprobe1 being obsoleted.
+# xprobe 2 has different approach to operating system fingerprinting.
+# Xprobe2 rely on fuzzy signature matching, probabilistic guesses, multiple
+# matches simultaneously, and a signature database.
+#
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-${PV}.tar.gz"
+HOMEPAGE="http://www.sys-security.com/html/projects/X.html"
+
+KEYWORDS="~x86 ~sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/libpcap"
+IUSE=""
+
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ cd "${WORKDIR}/${PN}2-${PV}"
+ econf || die "could not configure"
+ emake || die "could not make"
+}
+
+src_install () {
+ cd "${WORKDIR}/${PN}2-${PV}"
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS CREDITS COPYING
+ dodoc CHANGELOG TODO README
+ dodoc docs/*
+}
+