summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/w_scan/ChangeLog12
-rw-r--r--media-tv/w_scan/files/w_scan-20080105-build-and-path-fixes.patch118
-rw-r--r--media-tv/w_scan/metadata.xml2
-rw-r--r--media-tv/w_scan/w_scan-20080105.ebuild29
4 files changed, 158 insertions, 3 deletions
diff --git a/media-tv/w_scan/ChangeLog b/media-tv/w_scan/ChangeLog
index 37af8936c8a5..3bc55333eca2 100644
--- a/media-tv/w_scan/ChangeLog
+++ b/media-tv/w_scan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/w_scan
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.4 2007/03/13 12:00:42 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.5 2008/04/02 14:38:55 coldwind Exp $
+
+*w_scan-20080105 (02 Apr 2008)
+
+ 02 Apr 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/w_scan-20080105-build-and-path-fixes.patch, metadata.xml,
+ +w_scan-20080105.ebuild:
+ Version bump wrt bug #215761, fixed paths and honour CFLAGS, LDFLAGS and
+ CC.
13 Mar 2007; Matthias Schwarzott <zzam@gentoo.org> w_scan-20060903.ebuild:
Marked stable on x86.
diff --git a/media-tv/w_scan/files/w_scan-20080105-build-and-path-fixes.patch b/media-tv/w_scan/files/w_scan-20080105-build-and-path-fixes.patch
new file mode 100644
index 000000000000..b688fcfe3f9c
--- /dev/null
+++ b/media-tv/w_scan/files/w_scan-20080105-build-and-path-fixes.patch
@@ -0,0 +1,118 @@
+diff -ur w_scan-20080105.orig/Makefile w_scan-20080105/Makefile
+--- w_scan-20080105.orig/Makefile 2008-04-02 16:02:00.000000000 +0200
++++ w_scan-20080105/Makefile 2008-04-02 16:28:16.000000000 +0200
+@@ -1,7 +1,7 @@
+
+-CC = gcc
+-CFLAGS = -MD -g -Wall -O2
+-LFLAGS = -g -Wall
++CC ?= gcc
++ALL_CFLAGS = -MD -g -Wall -O2 $(CFLAGS)
++ALL_LDFLAGS = -g -Wall $(LDFLAGS)
+
+ OBJS = dump-vdr.o dump-xine.o dump-dvbscan.o dump-kaffeine.o scan.o
+ SRCS = $(OBJS:.o=.c)
+@@ -10,19 +10,26 @@
+ VERSION = $(shell sed -n '/uint version/p' scan.c | sed -e 's/uint version = //' | sed -e 's/;//')
+ TMPDIR = w_scan-$(VERSION)
+
++BINDIR = /usr/bin
++SHAREDIR = /usr/share/w_scan
++DOCDIR = /usr/share/doc/w_scan
++
+ $(TARGET): $(OBJS)
+- $(CC) $(LFLAGS) -o $(TARGET) $(OBJS)
++ $(CC) $(ALL_LDFLAGS) -o $(TARGET) $(OBJS)
+ $(RM) *.o *.d
+ .c.o:
+- $(CC) $(CFLAGS) --static -c $< -o $@
++ $(CC) $(ALL_CFLAGS) -c $< -o $@
+
+ install:
+- install -m 755 $(TARGET) /usr/bin
+- install -m 755 w_scan_start.sh /usr/bin
+- install pci.ids /usr/bin
+- install pci.classes /usr/bin
+- install usb.ids /usr/bin
+- install usb.classes /usr/bin
++ @mkdir -p $(DESTDIR)$(BINDIR)
++ @mkdir -p $(DESTDIR)$(SHAREDIR)
++ @mkdir -p $(DESTDIR)$(DOCDIR)
++ install -m 755 $(TARGET) $(DESTDIR)$(BINDIR)
++ install -m 755 w_scan_start.sh $(DESTDIR)$(BINDIR)
++ install pci.ids $(DESTDIR)$(SHAREDIR)
++ install pci.classes $(DESTDIR)$(SHAREDIR)
++ install usb.ids $(DESTDIR)$(SHAREDIR)
++ install usb.classes $(DESTDIR)$(SHAREDIR)
+
+ dist:
+ @-rm -rf $(TMPDIR)
+Los ficheros w_scan-20080105.orig/w_scan y w_scan-20080105/w_scan son distintos
+diff -ur w_scan-20080105.orig/w_scan_start.sh w_scan-20080105/w_scan_start.sh
+--- w_scan-20080105.orig/w_scan_start.sh 2008-04-02 16:02:00.000000000 +0200
++++ w_scan-20080105/w_scan_start.sh 2008-04-02 16:27:55.000000000 +0200
+@@ -414,8 +414,8 @@
+ read idVendor < $i/idVendor
+ read idProduct < $i/idProduct
+ # avoid errors if ressource not available
+- if [ ! -e $(pwd)/usb.ids ] ||
+- [ ! -e $(pwd)/usb.classes ]; then
++ if [ ! -e /usr/share/w_scan/usb.ids ] ||
++ [ ! -e /usr/share/w_scan/usb.classes ]; then
+ DEBUG_LOADDRIVER=false
+ fi
+ if [ $DEBUG_LOADDRIVER == true ]; then
+@@ -424,7 +424,7 @@
+ class_name=${line:6:40}
+ break
+ fi
+- done < $(pwd)/usb.classes
++ done < /usr/share/w_scan/usb.classes
+ while read line; do
+ if [ "${line:0:4}" == "$idVendor" ]; then
+ vendor_name=${line:6:80}
+@@ -438,7 +438,7 @@
+ done
+ break
+ fi
+- done < $(pwd)/usb.ids
++ done < /usr/share/w_scan/usb.ids
+ fi
+ while read line; do
+ data=$line
+@@ -507,8 +507,8 @@
+ read subvendor < $i/subsystem_vendor
+ read subdevice < $i/subsystem_device
+ # avoid errors if ressource not available
+- if [ ! -e $(pwd)/pci.ids ] ||
+- [ ! -e $(pwd)/pci.classes ]; then
++ if [ ! -e /usr/share/w_scan/pci.ids ] ||
++ [ ! -e /usr/share/w_scan/pci.classes ]; then
+ DEBUG_LOADDRIVER=false
+ fi
+ if [ $DEBUG_LOADDRIVER == true ]; then
+@@ -517,7 +517,7 @@
+ class_name=${line:5:40}
+ break
+ fi
+- done < $(pwd)/pci.classes
++ done < /usr/share/w_scan/pci.classes
+ while read line; do
+ if [ "${line:0:4}" == "${vendor:2:4}" ]; then
+ vendor_name=${line:5:80}
+@@ -531,13 +531,13 @@
+ done
+ break
+ fi
+- done < $(pwd)/pci.ids
++ done < /usr/share/w_scan/pci.ids
+ while read line; do
+ if [ "${line:0:4}" == "${subvendor:2:4}" ]; then
+ subvendor_name=${line:5:80}
+ break
+ fi
+- done < $(pwd)/pci.ids
++ done < /usr/share/w_scan/pci.ids
+ fi
+ while read line; do
+ data=$line
diff --git a/media-tv/w_scan/metadata.xml b/media-tv/w_scan/metadata.xml
index c957466cfa5f..3dee80576fe9 100644
--- a/media-tv/w_scan/metadata.xml
+++ b/media-tv/w_scan/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>media-tv</herd>
<maintainer>
-<email>media-tv@gentoo.org</email>
+ <email>coldwind@gentoo.org</email>
</maintainer>
</pkgmetadata>
diff --git a/media-tv/w_scan/w_scan-20080105.ebuild b/media-tv/w_scan/w_scan-20080105.ebuild
new file mode 100644
index 000000000000..2e57f9cb5a63
--- /dev/null
+++ b/media-tv/w_scan/w_scan-20080105.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/w_scan-20080105.ebuild,v 1.1 2008/04/02 14:38:55 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="Scan for DVB-C/DVB-T channels without prior knowledge of frequencies and modulations - can also create a file in vdr-format"
+HOMEPAGE="http://free.pages.at/wirbel4vdr/w_scan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-tv/linuxtv-dvb-headers"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build-and-path-fixes.patch"
+ emake clean || die "emake clean failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README
+}