summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/tk707')
-rw-r--r--media-sound/tk707/ChangeLog6
-rw-r--r--media-sound/tk707/tk707-0.8-r1.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/media-sound/tk707/ChangeLog b/media-sound/tk707/ChangeLog
index 46cb61e02932..b6402ee2e057 100644
--- a/media-sound/tk707/ChangeLog
+++ b/media-sound/tk707/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/tk707
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/ChangeLog,v 1.4 2005/07/25 19:15:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/ChangeLog,v 1.5 2005/11/03 12:44:13 flameeyes Exp $
+
+ 03 Nov 2005; Diego Pettenò <flameeyes@gentoo.org> tk707-0.8-r1.ebuild:
+ Fix DEPEND/RDEPEND that got reversed. Use autotools eclass insetad of
+ autoreconf.
25 Jul 2005; David Holm <dholm@gentoo.org> tk707-0.8-r1.ebuild:
Added to ~ppc.
diff --git a/media-sound/tk707/tk707-0.8-r1.ebuild b/media-sound/tk707/tk707-0.8-r1.ebuild
index fa53836990e1..58a14e7723a2 100644
--- a/media-sound/tk707/tk707-0.8-r1.ebuild
+++ b/media-sound/tk707/tk707-0.8-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/tk707-0.8-r1.ebuild,v 1.3 2005/07/25 19:15:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tk707/tk707-0.8-r1.ebuild,v 1.4 2005/11/03 12:44:13 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION=" An \"7x7\" type midi drum sequencer for Linux"
HOMEPAGE="http://www-lmc.imag.fr/lmc-edp/Pierre.Saramito/tk707"
@@ -14,20 +14,22 @@ KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND=">=media-libs/alsa-lib-0.9.0
+RDEPEND=">=media-libs/alsa-lib-0.9.0
>=dev-lang/tcl-8.4
>=dev-lang/tk-8.4"
-RDEPEND="${DEPEND}
+DEPEND="${RDEPEND}
>=sys-devel/automake-1.7
>=sys-devel/autoconf-2.5"
src_unpack() {
unpack ${A}
EPATCH_SOURCE=${S} epatch ${P}-*.patch
+
+ cd "${S}"
+ eautoreconf
}
src_compile() {
- autoreconf || die "autoreconf failed"
econf $(use_enable timdity) $(use_enable lame) || die "econf failed"
emake || die "emake failed"
}