summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/liquidwar/liquidwar-5.5.8.ebuild')
-rw-r--r--games-strategy/liquidwar/liquidwar-5.5.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-strategy/liquidwar/liquidwar-5.5.8.ebuild b/games-strategy/liquidwar/liquidwar-5.5.8.ebuild
new file mode 100644
index 000000000000..838e262da13c
--- /dev/null
+++ b/games-strategy/liquidwar/liquidwar-5.5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/liquidwar-5.5.8.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="unique multiplayer wargame"
+HOMEPAGE="http://www.ufoot.org/liquidwar/"
+SRC_URI="http://freesoftware.fsf.org/download/liquidwar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">media-libs/allegro-4.0"
+
+src_compile() {
+ econf --disable-doc-ps --disable-doc-pdf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ cd ${D}/usr/games
+ mkdir bin
+ mv liquidwar liquidwar-server bin/
+ rm -rf ${D}/usr/bin
+
+ prepgamesdirs
+}