summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/searchandrescue')
-rw-r--r--games-simulation/searchandrescue/ChangeLog8
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild14
2 files changed, 16 insertions, 6 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 83d2a29304c8..34780be9a8c9 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/searchandrescue
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.13 2007/05/31 20:55:43 tupone Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.14 2009/02/16 17:53:24 mr_bones_ Exp $
+
+ 16 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ searchandrescue-0.8.2-r1.ebuild:
+ EAPI=2
*searchandrescue-0.8.2-r1 (31 May 2007)
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
index 64852d7a7597..6ed36b909bb4 100644
--- a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.1 2007/05/31 20:55:43 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.2 2009/02/16 17:53:24 mr_bones_ Exp $
+EAPI=2
inherit eutils games
MY_PN=SearchAndRescue
@@ -33,7 +34,9 @@ src_unpack() {
unpack ${MY_PN}-${PV}.tar.bz2
mkdir data ; cd data
unpack ${MY_PN}-data-${PV}.tar.bz2
- cd "${S}"
+}
+
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc33.patch \
"${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-gcc412.patch
@@ -47,7 +50,7 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
+src_configure() {
local myconf
use joystick \
@@ -59,6 +62,9 @@ src_compile() {
--prefix="${GAMES_PREFIX}" \
${myconf} \
|| die
+}
+
+src_compile() {
emake -j1 || die "emake failed"
}