summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/ChangeLog8
-rw-r--r--games-puzzle/monsterz/files/digest-monsterz-0.6.01
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.6.0-gentoo.patch19
-rw-r--r--games-puzzle/monsterz/monsterz-0.6.0.ebuild41
4 files changed, 68 insertions, 1 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index a614abd660bf..bff06a54779b 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/monsterz
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.3 2005/03/24 05:42:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.4 2005/04/09 07:28:53 vapier Exp $
+
+*monsterz-0.6.0 (09 Apr 2005)
+
+ 09 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/monsterz-0.6.0-gentoo.patch, +monsterz-0.6.0.ebuild:
+ Version bump.
*monsterz-0.4.2 (24 Mar 2005)
diff --git a/games-puzzle/monsterz/files/digest-monsterz-0.6.0 b/games-puzzle/monsterz/files/digest-monsterz-0.6.0
new file mode 100644
index 000000000000..12d33b1313f9
--- /dev/null
+++ b/games-puzzle/monsterz/files/digest-monsterz-0.6.0
@@ -0,0 +1 @@
+MD5 af2ecbd5671b3b57b3c16a0374825ff6 monsterz-0.6.0.tar.gz 2490036
diff --git a/games-puzzle/monsterz/files/monsterz-0.6.0-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.6.0-gentoo.patch
new file mode 100644
index 000000000000..47b0cd5ae602
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.6.0-gentoo.patch
@@ -0,0 +1,19 @@
+--- monsterz.py
++++ monsterz.py
+@@ -24,5 +24,4 @@
+ COPYRIGHT = 'MONSTERZ - COPYRIGHT 2005 SAM HOCEVAR - MONSTERZ IS ' \
+ 'FREE SOFTWARE, YOU CAN REDISTRIBUTE IT AND/OR MODIFY IT ' \
+- 'UNDER THE TERMS OF THE DO WHAT THE FUCK YOU WANT TO ' \
+- 'PUBLIC LICENSE, VERSION 2 - '
++ 'UNDER THE TERMS OF THE WTFPL, Version 2 - '
+
+@@ -1896,3 +1380,3 @@
+ print 'This is free software; you can redistribute it and/or modify it under the terms'
+- print 'of the Do What The Fuck You Want To Public License, Version 2, as published'
++ print 'of the WTFPL, Version 2, as published'
+ print 'by Sam Hocevar. See http://sam.zoy.org/projects/COPYING.WTFPL for more details.'
+@@ -1900,3 +1900,3 @@
+ scorefile = None
+- sharedir = dirname(argv[0])
++ sharedir = "GENTOO_DATADIR"
+ outfd = None
diff --git a/games-puzzle/monsterz/monsterz-0.6.0.ebuild b/games-puzzle/monsterz/monsterz-0.6.0.ebuild
new file mode 100644
index 000000000000..5827090f1b96
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.6.0.ebuild,v 1.1 2005/04/09 07:28:53 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pygame"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "${PN} requires that media-libs/sdl-mixer be built with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+ insinto "${dir}"
+ doins -r graphics sound || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "dobin failed"
+ dodoc README AUTHORS TODO INSTALL
+ prepgamesdirs
+}