summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/ck/ChangeLog5
-rw-r--r--dev-tcltk/ck/ck-8.0.ebuild4
-rw-r--r--dev-tcltk/otcl/ChangeLog5
-rw-r--r--dev-tcltk/otcl/otcl-1.8-r1.ebuild4
4 files changed, 12 insertions, 6 deletions
diff --git a/dev-tcltk/ck/ChangeLog b/dev-tcltk/ck/ChangeLog
index 0e78c68cecaa..5d7f2a67f257 100644
--- a/dev-tcltk/ck/ChangeLog
+++ b/dev-tcltk/ck/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/ck
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/ck/ChangeLog,v 1.3 2004/04/04 22:04:09 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/ck/ChangeLog,v 1.4 2004/04/26 01:32:07 agriffis Exp $
+
+ 25 Apr 2004; Aron Griffis <agriffis@gentoo.org> ck-8.0.ebuild:
+ Add die following econf for bug 48950
04 Apr 2004; Chris Aniszczyk <zx@gentoo.org> ck-8.0.ebuild, metadata.xml:
Added missing metadata.xml
diff --git a/dev-tcltk/ck/ck-8.0.ebuild b/dev-tcltk/ck/ck-8.0.ebuild
index 2b086b8861df..d8a6f12267cc 100644
--- a/dev-tcltk/ck/ck-8.0.ebuild
+++ b/dev-tcltk/ck/ck-8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/ck/ck-8.0.ebuild,v 1.7 2004/04/04 22:04:09 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/ck/ck-8.0.ebuild,v 1.8 2004/04/26 01:32:07 agriffis Exp $
P_NEW=${PN}${PV}
S=${WORKDIR}/${P_NEW}
@@ -17,7 +17,7 @@ DEPEND=">=dev-lang/tk-8.0
src_compile() {
local myconf="--with-tcl=/usr/lib --enable-shared"
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
emake CFLAGS="${CFLAGS}" || die
# patch Makefile
diff --git a/dev-tcltk/otcl/ChangeLog b/dev-tcltk/otcl/ChangeLog
index 69382e0b1b29..37ba307a727d 100644
--- a/dev-tcltk/otcl/ChangeLog
+++ b/dev-tcltk/otcl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/otcl
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.6 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.7 2004/04/26 01:36:17 agriffis Exp $
+
+ 25 Apr 2004; Aron Griffis <agriffis@gentoo.org> otcl-1.8-r1.ebuild:
+ Add die following econf for bug 48950
14 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> otcl-1.8-r1.ebuild:
Inherit eutils.
diff --git a/dev-tcltk/otcl/otcl-1.8-r1.ebuild b/dev-tcltk/otcl/otcl-1.8-r1.ebuild
index 3b931bafe57e..102c01be76b0 100644
--- a/dev-tcltk/otcl/otcl-1.8-r1.ebuild
+++ b/dev-tcltk/otcl/otcl-1.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.8-r1.ebuild,v 1.3 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.8-r1.ebuild,v 1.4 2004/04/26 01:36:17 agriffis Exp $
inherit eutils
@@ -24,7 +24,7 @@ src_compile() {
#local myconf="--with-tcl=/usr/lib --enable-shared"
local myconf="--enable-shared"
CFLAGS="${CFLAGS} -I`ls /usr/lib/tcl8.*/include/generic/tclInt.h | tail -n1 | xargs dirname`"
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
emake all || die
emake libotcl.so || die
}