summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-4.1.10.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.1.10.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-4.1.10.ebuild b/dev-ruby/actionmailer/actionmailer-4.1.10.ebuild
deleted file mode 100644
index 1d839b08e0a2..000000000000
--- a/dev-ruby/actionmailer/actionmailer-4.1.10.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.1.10.ebuild,v 1.1 2015/03/19 19:25:06 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Framework for designing email-service layers"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/actionpack-${PV}
- >=dev-ruby/mail-2.5.4:2.5"
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/mocha:0.14
-)"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|uglifier\|minitest\)/ s:^:#:" \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- rm ../Gemfile.lock || die
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
-
- # Avoid a test failing only on attachment ordering, since this is a
- # security release.
- sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
-}