summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astng')
-rw-r--r--dev-python/astng/ChangeLog8
-rw-r--r--dev-python/astng/astng-0.17.2.ebuild63
-rw-r--r--dev-python/astng/astng-0.19.1.ebuild64
3 files changed, 71 insertions, 64 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index fcb33428f48b..c0fa7293893c 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.23 2009/08/25 14:51:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.24 2009/09/04 22:34:41 arfrever Exp $
+
+*astng-0.19.1 (04 Sep 2009)
+
+ 04 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -astng-0.17.2.ebuild, +astng-0.19.1.ebuild:
+ Version bump.
25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
astng-0.19.0.ebuild:
diff --git a/dev-python/astng/astng-0.17.2.ebuild b/dev-python/astng/astng-0.17.2.ebuild
deleted file mode 100644
index 055e41a17e3d..000000000000
--- a/dev-python/astng/astng-0.17.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.17.2.ebuild,v 1.1 2008/02/28 20:37:47 dev-zero Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils multilib
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/astng/"
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="GPL-2"
-
-DEPEND=">=dev-python/logilab-common-0.13-r1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/logilab-${P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Skip a failing test.
- epatch "${FILESDIR}/${PN}-0.16.1-skip-gobject-test.patch"
-}
-
-src_install() {
- distutils_src_install
- python_version
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
-}
-
-src_test() {
- python_version
-
- # Do a temporary install.
- local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
-
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${T}/test/${spath}/logilab"
- cp -r "/${spath}/logilab/common" "${T}/test/${spath}/logilab" \
- || die "copying logilab-common failed!"
-
- "${python}" setup.py install --root="${T}/test" || die "test copy failed"
-
- # Use a hacked up copy of pytest that exits nonzero on failure.
- sed -e 's/exitafter=False/exitafter=True/' \
- < "/usr/bin/pytest" > "${T}/pytest" || die "sed failed"
-
- # Pytest picks up tests relative to the current dir, so cd in.
- pushd "${T}/test/${spath}/logilab/astng" >/dev/null
- PYTHONPATH="${T}/test/${spath}" "${python}" "${T}/pytest" -v \
- || die "tests failed"
- popd >/dev/null
- rm -rf "${T}/test"
-}
diff --git a/dev-python/astng/astng-0.19.1.ebuild b/dev-python/astng/astng-0.19.1.ebuild
new file mode 100644
index 000000000000..14aeb640f42e
--- /dev/null
+++ b/dev-python/astng/astng-0.19.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.19.1.ebuild,v 1.1 2009/09/04 22:34:41 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+HOMEPAGE="http://www.logilab.org/projects/astng/"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/logilab-common-0.39.0"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/egenix-mx-base-3.0.0 )"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="logilab"
+
+S="${WORKDIR}/logilab-${P}"
+
+src_test() {
+ testing() {
+ local sdir="${T}/test/$(python_get_sitedir)"
+
+ # This is a hack to make tests work without installing to the live
+ # filesystem. We copy part of the logilab site-packages to a temporary
+ # dir, install there, and run from there.
+ mkdir -p "${sdir}/logilab" || die
+ cp -r "$(python_get_sitedir)/logilab/common" "${sdir}/logilab" || die "copying logilab-common failed!"
+
+ "$(PYTHON)" setup.py install --root="${T}/test" || die "test copy failed"
+
+ # Pytest picks up tests relative to the current dir, so cd in.
+ pushd "${sdir}/logilab/astng" > /dev/null || die
+ PYTHONPATH="${sdir}" pytest -v || die "tests failed"
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ deletion_of_unneeded_files() {
+ local sdir="${D}/$(python_get_sitedir)/logilab"
+
+ # we need to remove this file because it collides with the one
+ # from logilab-common (which we depend on).
+ # Bug 111970 and bug 223025
+ rm "${sdir}/__init__.py" || die
+
+ # Remove unittests since they're just needed during build-time
+ rm -rf "${sdir}/astng/test" || die
+ }
+ python_execute_function --action-message 'Deletion of unneeded files with Python ${PYTHON_ABI}' deletion_of_unneeded_files
+}