summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jython')
-rw-r--r--dev-java/jython/ChangeLog38
-rw-r--r--dev-java/jython/files/digest-jython-2.1-r41
-rw-r--r--dev-java/jython/files/jython7
-rw-r--r--dev-java/jython/files/jythonc7
-rw-r--r--dev-java/jython/jython-2.1-r4.ebuild83
-rw-r--r--dev-java/jython/metadata.xml5
6 files changed, 141 insertions, 0 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
new file mode 100644
index 000000000000..923d2c6f8bd7
--- /dev/null
+++ b/dev-java/jython/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for dev-java/jython
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.10 2004/07/31 15:51:57 karltk Exp $
+
+ 31 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org>:
+ jython-2.1-r4.ebuild: Rewrote almost totally to compile from source. Ugly hack
+ that needs more attention.
+
+ 16 Jul 2004; Thomas Matthijs <axxo@gentoo.org> :
+ fix python.home path in files/jython closes 49841
+ fix path in jythonc (although it still doesn't work, looks like it never did
+ if you know how to fix it, please let me know or file a bug on bugzilla)
+
+ 19 Jun 2004; Jason Wever <weeve@gentoo.org> jython-2.1-r2.ebuild:
+ Stable on sparc.
+
+ 19 Jan 2004; Adrian Almenar <strider@gentoo.org> jython-2.1-r2.ebuild:
+ Added amd64 keyword.
+
+*jython-2.1-r2 (17 Jan 2004)
+
+ 17 Jan 2004; Adrian Almenar <strider@gentoo.org> jython-2.1-r1.ebuild,
+ jython-2.1-r2.ebuild, jython-2.1.ebuild:
+ Fixes #25533. Ebuild submitted by Chris Aniszczyk <zx@mea-culpa.net>. Moved
+ 2.1-r1 to stable, Removed 2.1.
+
+*jython-2.1-r1 (13 May 2003)
+
+ 13 May 2003; Todd Berman <tberman@gentoo.org> jython-2.1-r1.ebuild,
+ files/jython, files/jythonc:
+ Fixed up ebuild, closing bug #20562, bumped revision # for people with it
+ already installed.
+
+*jython-2.1 (29 Apr 2003)
+
+ 29 Apr 2003; Todd Berman <tberman@gentoo.org> jython-2.1.ebuild:
+ Initial import.
+
diff --git a/dev-java/jython/files/digest-jython-2.1-r4 b/dev-java/jython/files/digest-jython-2.1-r4
new file mode 100644
index 000000000000..de8e46ef8258
--- /dev/null
+++ b/dev-java/jython/files/digest-jython-2.1-r4
@@ -0,0 +1 @@
+MD5 e3e6be56646fb7cd6d19a6a69bd76e2f jython-21.class 2780547
diff --git a/dev-java/jython/files/jython b/dev-java/jython/files/jython
new file mode 100644
index 000000000000..551b764606f5
--- /dev/null
+++ b/dev-java/jython/files/jython
@@ -0,0 +1,7 @@
+#!/bin/sh
+###############################################################################
+#
+# This file generated by Jython installer
+# Created on XXX by root
+
+`java-config --java` -Dpython.home="/var/jython" -classpath "`java-config --classpath=jython`:$CLASSPATH" "org.python.util.jython" "$@"
diff --git a/dev-java/jython/files/jythonc b/dev-java/jython/files/jythonc
new file mode 100644
index 000000000000..21adc6bca570
--- /dev/null
+++ b/dev-java/jython/files/jythonc
@@ -0,0 +1,7 @@
+#!/bin/sh
+###############################################################################
+#
+# This file generated by Jython installer
+# Created on XXX by root
+
+jython "/var/jython/Tools/jythonc/jythonc.py" "$@"
diff --git a/dev-java/jython/jython-2.1-r4.ebuild b/dev-java/jython/jython-2.1-r4.ebuild
new file mode 100644
index 000000000000..d7c0d4edd27e
--- /dev/null
+++ b/dev-java/jython/jython-2.1-r4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r4.ebuild,v 1.1 2004/07/31 15:51:57 karltk Exp $
+
+DESCRIPTION="An implementation of Python written in Java"
+HOMEPAGE="http://www.jython.org"
+MY_PV="21"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
+LICENSE="JPython"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="readline"
+# servlet
+
+DEPEND=">=virtual/jdk-1.2
+ readline? ( >=dev-java/libreadline-java-0.8.0 )
+ jikes? ( >=dev-java/jikes-1.18 )
+ "
+# servlet? ( >=net-www/tomcat-5.0 )
+
+src_unpack() {
+ addwrite .hotspot
+ cd ${DISTDIR}
+ java ${PN}-${MY_PV} -o ${S}/ demo lib source
+}
+
+compile_set() {
+
+ for x in $* ; do
+ if [ -d $x ] ; then
+ find $* -name "*.java" | xargs ${javac} -source 1.3 -nowarn
+ else
+ ${javac} -source 1.3 -nowarn $x
+ fi
+ done
+}
+
+src_compile() {
+
+ javac=$(java-config -c)
+ if use jikes ; then
+ java=$(which jikes)
+ fi
+
+ # 2004-07-31: karltk
+ # Hack to not clutter up the CLASSPATH env var globally
+ (
+ export CLASSPATH="/opt/sun-jdk-1.4.2.04/jre/lib/rt.jar"
+
+ compile_set org/python/core org/python/rmi org/python/parser
+
+ compile_set org/python/util/jython.java
+
+ if use readline ; then
+ export CLASSPATH="${CLASSPATH}:$(java-config -p libreadline-java)"
+ compile_set org/python/util/ReadlineConsole.java
+ fi
+
+ # 2004-07-31: karltk
+ # Need to add back in most of org/python/modules/
+# if use servlet ; then
+# CLASSPATH="${CLASSPATH}:$(java-config -p servlet)"
+# compile_set org/python/util/PyServlet.java
+# fi
+
+ find org -name "*.class" | xargs jar cf jython-${PV}.jar
+ )
+}
+
+src_install() {
+ dojar jython-${PV}.jar
+ dodoc {README,LICENSE}.txt NEWS ACKNOWLEDGMENTS
+ dohtml -A .css .jpg .gif -r Doc
+ newbin ${FILESDIR}/jython jython
+ newbin ${FILESDIR}/jythonc jythonc
+
+ dodir /usr/share/jython/cachedir
+ chmod a+rw ${D}/usr/share/jython/cachedir
+
+ cp -R Lib/* ${D}/usr/share/${PN}/lib/
+ mkdir ${D}/usr/share/${PN}/tools/
+ cp -R Tools/* ${D}/usr/share/${PN}/tools/
+}
diff --git a/dev-java/jython/metadata.xml b/dev-java/jython/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jython/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>