summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mmap')
-rw-r--r--dev-haskell/mmap/ChangeLog7
-rw-r--r--dev-haskell/mmap/mmap-0.5.9.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-haskell/mmap/ChangeLog b/dev-haskell/mmap/ChangeLog
index 7148a2e730ca..4bd861ca89af 100644
--- a/dev-haskell/mmap/ChangeLog
+++ b/dev-haskell/mmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/mmap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.31 2013/06/18 21:23:21 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.32 2013/09/13 08:48:32 gienah Exp $
+
+*mmap-0.5.9 (13 Sep 2013)
+
+ 13 Sep 2013; Mark Wright <gienah@gentoo.org> +mmap-0.5.9.ebuild:
+ Bump mmap to 0.5.9
18 Jun 2013; Sergei Trofimovich <slyfox@gentoo.org> -mmap-0.4.1.ebuild,
-mmap-0.5.7.ebuild:
diff --git a/dev-haskell/mmap/mmap-0.5.9.ebuild b/dev-haskell/mmap/mmap-0.5.9.ebuild
new file mode 100644
index 000000000000..d1575bb9ae8e
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/mmap-0.5.9.ebuild,v 1.1 2013/09/13 08:48:32 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}