summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/xmlada/ChangeLog8
-rw-r--r--dev-ada/xmlada/files/digest-xmlada-2.2.0-r13
-rw-r--r--dev-ada/xmlada/xmlada-2.2.0-r1.ebuild102
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-ada/xmlada/ChangeLog b/dev-ada/xmlada/ChangeLog
index 173d4a5fbdb2..e8dc75abe88c 100644
--- a/dev-ada/xmlada/ChangeLog
+++ b/dev-ada/xmlada/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/xmlada
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.25 2007/09/25 13:06:19 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.26 2007/12/14 12:22:23 george Exp $
+
+*xmlada-2.2.0-r1 (14 Dec 2007)
+
+ 14 Dec 2007; George Shapovalov <george@gentoo.org>
+ +xmlada-2.2.0-r1.ebuild:
+ transitioned xmlada to use unified layout (common bin/ for Ada libs, etc)
25 Sep 2007; George Shapovalov <george@gentoo.org> xmlada-1.0-r4.ebuild:
adjusted ebuild to follow eclass reorg, gnat_src_unpack was factored out
diff --git a/dev-ada/xmlada/files/digest-xmlada-2.2.0-r1 b/dev-ada/xmlada/files/digest-xmlada-2.2.0-r1
new file mode 100644
index 000000000000..b01804e353aa
--- /dev/null
+++ b/dev-ada/xmlada/files/digest-xmlada-2.2.0-r1
@@ -0,0 +1,3 @@
+MD5 e7d1601603f3ee67bbd0233bc2f35198 xmlada-2.2.0.tar.bz2 591666
+RMD160 835c44aca5810a1ebab1840df7fc929012b87ed1 xmlada-2.2.0.tar.bz2 591666
+SHA256 3935a1a158a120bb53d5417a518b7283b5d97f478cf3af0f5e02222ae3b5c7b4 xmlada-2.2.0.tar.bz2 591666
diff --git a/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild b/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..d0c8cdfe3bf5
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild,v 1.1 2007/12/14 12:22:23 george Exp $
+
+inherit gnat versionator
+
+IUSE=""
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.adacore.com/xmlada/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/gnat
+ virtual/tetex
+ sys-apps/texinfo
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # adjusting profile independent stuff in project files
+# for fn in distrib/*/xmlada*.gpr; do
+# sed -i -e "s:../../include/xmlada:${AdalibSpecsDir}/${PN}:" ${fn}
+# done
+ sed -i -e "s:\.\./\.\./include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ distrib/*/xmlada*.gpr || die "failed to adjust project files"
+
+ # fix profile independent stuff in xmlada-config
+ sed -i -e "s:\${prefix}/include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ xmlada-config.in || die "failed to adjust xmlada-config"
+
+ # doinfo changed from gzipping stuff to bzipping, so we better rename the
+ # file before calling it to guard against other possible changes
+ mv docs/xml.info docs/${PN}.info
+}
+
+lib_compile()
+{
+ econf
+ emake
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install() {
+ make PREFIX="${DL}" install || die "install failed"
+
+ pushd "${DL}"
+ # fix xmlada-config hardsets locations and move it to proper location
+ sed -i -e "s:\${prefix}/lib/xmlada:${AdalibLibTop}/$1/${PN}:" \
+ -e "s:\${prefix}/lib:${AdalibLibTop}/$1/${PN}:g" \
+ bin/xmlada-config
+ mv bin/xmlada-config "${DLbin}"
+
+ # sed and organize gpr files
+ sed -i -e "s:\.\./xmlada:${AdalibLibTop}/$1/${PN}:" "${DL}"/lib/gnat/*.gpr
+ mv lib/gnat/* "${DLgpr}"
+
+ # the library and *.ali
+ mv lib/${PN}/* .
+ rm -rf bin include share lib
+
+ # fix the .so links
+ rm *.so
+ for fn in *.so.* ; do
+ ln -s ${fn} ${fn%so*}so
+ done
+ popd
+}
+
+src_install ()
+{
+ cd "${S}"
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins dom/*.ad? input_sources/*.ad? sax/*.ad? unicode/*.ad? schema/*.ad?
+
+ #set up environment
+ echo "PATH=%DLbin%" > ${LibEnv}
+ echo "LDPATH=%DL%" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}" >> ${LibEnv}
+ echo "ADA_PROJECT_PATH=%DLgpr%" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc AUTHORS COPYING README TODO features
+ dohtml docs/*.html
+ doinfo docs/*.info
+ insinto /usr/share/doc/${PF}
+ doins docs/*.pdf distrib/xmlada_gps.py
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r docs/{dom,sax,schema}
+}