summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/gnome-pilot')
-rw-r--r--app-pda/gnome-pilot/ChangeLog11
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild57
2 files changed, 66 insertions, 2 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index 65a2ce4c6745..690f25d19af3 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/gnome-pilot
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.62 2009/11/01 13:43:09 leio Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.63 2010/10/27 21:51:01 eva Exp $
+
+*gnome-pilot-2.32.0 (27 Oct 2010)
+
+ 27 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-pilot-2.32.0.ebuild:
+ Version bump. Update usage of gnome APIs. Move eds conduits support to
+ gnome-pilot.
01 Nov 2009; Mart Raudsepp <leio@gentoo.org> -gnome-pilot-2.0.17.ebuild:
Remove old
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild
new file mode 100644
index 000000000000..f225856f332e
--- /dev/null
+++ b/app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild,v 1.1 2010/10/27 21:51:01 eva Exp $
+
+EAPI="3"
+G2CONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Gnome Palm Pilot and Palm OS Device Syncing Library"
+HOMEPAGE="http://live.gnome.org/GnomePilot"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="eds hal"
+
+RDEPEND="
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/gconf-2
+ dev-libs/libxml2
+ >=app-pda/pilot-link-0.11.7
+ >=x11-libs/gtk+-2.13:2
+ >=dev-libs/dbus-glib-0.74
+
+ eds? ( >=gnome-extra/evolution-data-server-2 )
+ hal? ( >=sys-apps/hal-0.5.4 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/gob-2.0.5
+ >=dev-lang/perl-5.6
+ >=app-text/scrollkeeper-0.3.14
+ >=dev-util/intltool-0.35.5"
+
+pkg_setup() {
+ DOCS="AUTHORS COPYING* ChangeLog README NEWS"
+ G2CONF="${G2CONF}
+ --enable-usb
+ --enable-network
+ --enable-pilotlinktest
+ --disable-static
+ $(use_enable eds eds-conduits)
+ $(use_with hal)"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}"/usr/$(get_libdir)/${PN}/conduits -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ if ! has_version "app-pda/pilot-link[bluetooth]"; then
+ elog "if you want bluetooth support, please rebuild app-pda/pilot-link"
+ elog "echo 'app-pda/pilot-link bluetooth >> /etc/portage/package.use"
+ fi
+}