summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/protbuf')
-rw-r--r--app-emacs/protbuf/ChangeLog11
-rw-r--r--app-emacs/protbuf/files/50protbuf-gentoo.el5
-rw-r--r--app-emacs/protbuf/files/digest-protbuf-1.71
-rw-r--r--app-emacs/protbuf/protbuf-1.7.ebuild38
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/protbuf/ChangeLog b/app-emacs/protbuf/ChangeLog
new file mode 100644
index 000000000000..1da1a9741f27
--- /dev/null
+++ b/app-emacs/protbuf/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/protbuf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/protbuf/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*protbuf-1.7 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ protbuf-1.7.ebuild, files/50protbuf-gentoo.el,
+ files/digest-protbuf-1.7 :
+
+ Initial import.
diff --git a/app-emacs/protbuf/files/50protbuf-gentoo.el b/app-emacs/protbuf/files/50protbuf-gentoo.el
new file mode 100644
index 000000000000..99311ef79984
--- /dev/null
+++ b/app-emacs/protbuf/files/50protbuf-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; protbuf site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'protbuf)
diff --git a/app-emacs/protbuf/files/digest-protbuf-1.7 b/app-emacs/protbuf/files/digest-protbuf-1.7
new file mode 100644
index 000000000000..b65b5d143a23
--- /dev/null
+++ b/app-emacs/protbuf/files/digest-protbuf-1.7
@@ -0,0 +1 @@
+MD5 02b0c5c812d3bae8bcb2f9af032ce2e0 protbuf-1.7.tar.bz2 2270
diff --git a/app-emacs/protbuf/protbuf-1.7.ebuild b/app-emacs/protbuf/protbuf-1.7.ebuild
new file mode 100644
index 000000000000..666492d060e8
--- /dev/null
+++ b/app-emacs/protbuf/protbuf-1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/protbuf/protbuf-1.7.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Protect Emacs buffers from accidental killing."
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?ProtectingBuffers"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50protbuf-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/protbuf.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}