summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.3-r1.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.3-r1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
index 815d699fcc84..26ed024f7c9c 100644
--- a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.10 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.11 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -21,6 +21,8 @@ RDEPEND="media-gfx/graphviz
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -51,13 +53,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"./configure" failed.'
+ # and compile
emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.