summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/denyhosts/denyhosts-2.2.ebuild')
-rw-r--r--app-admin/denyhosts/denyhosts-2.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/denyhosts/denyhosts-2.2.ebuild b/app-admin/denyhosts/denyhosts-2.2.ebuild
new file mode 100644
index 000000000000..2fd7fad5cc42
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-2.2.ebuild,v 1.1 2006/03/30 10:11:56 strerror Exp $
+
+inherit distutils eutils
+
+my_PN="DenyHosts"
+my_P="${my_PN}-${PV}"
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://www.denyhosts.net"
+SRC_URI="mirror://sourceforge/${PN}/${my_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3"
+S="${WORKDIR}/${my_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # changes default file installations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e 's:#!/usr/bin/env python:#!/usr/bin/python:' \
+ denyhosts.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf
+
+ newinitd "${FILESDIR}"/denyhosts.init denyhosts
+
+ exeinto /usr/bin
+ newexe denyhosts.py denyhosts
+
+ dodoc CHANGELOG.txt README.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ if [ ! -f /etc/hosts.deny ]
+ then
+ touch /etc/hosts.deny
+ fi
+
+ einfo "You can configure DenyHosts to run as a daemon by running:"
+ einfo
+ einfo "rc-update add denyhosts default"
+ einfo
+ einfo "or as a cronjob, by adding the following to /etc/crontab"
+ einfo "# run DenyHosts every 10 minutes"
+ einfo "*/10 * * * * root python /usr/bin/denyhosts -c /etc/denyhosts.conf"
+ einfo
+ einfo "More information can be found at http://denyhosts.sourceforge.net/faq.html"
+ einfo
+ ewarn "Modify /etc/denyhosts.conf to suit your environment system."
+}
+