summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gconf/ChangeLog5
-rw-r--r--gnome-base/gconf/files/digest-gconf-2.16.03
-rw-r--r--gnome-base/gconf/gconf-2.16.0.ebuild84
3 files changed, 91 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 7cd17dc86087..a73a5f9ca007 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.159 2007/01/16 13:45:55 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.160 2007/03/23 21:34:07 dang Exp $
+
+ 23 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> +gconf-2.16.0.ebuild:
+ add gnome 2.18.0
16 Jan 2007; Roy Marples <uberlord@gentoo.org> gconf-2.14.0.ebuild:
Added ~x86-fbsd keyword.
diff --git a/gnome-base/gconf/files/digest-gconf-2.16.0 b/gnome-base/gconf/files/digest-gconf-2.16.0
new file mode 100644
index 000000000000..e13c5ad0a1ea
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-2.16.0
@@ -0,0 +1,3 @@
+MD5 b1a202f36661c0d9c87f8fe27a28bd52 GConf-2.16.0.tar.bz2 1307732
+RMD160 b3c429a45ac96cf79b7231666ecb8e1de645a4f8 GConf-2.16.0.tar.bz2 1307732
+SHA256 d687ea919e20e08c42eeedf32e40f0845cd6799dbfa2edec9dbc644d386805c2 GConf-2.16.0.tar.bz2 1307732
diff --git a/gnome-base/gconf/gconf-2.16.0.ebuild b/gnome-base/gconf/gconf-2.16.0.ebuild
new file mode 100644
index 000000000000..34ac9b2098fe
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.16.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.16.0.ebuild,v 1.1 2007/03/23 21:34:07 dang Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.16
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# FIXME : consider merging the tree (?)
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gtk"
+ kill_gconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die
+ dodir /root/.gconfd
+}
+
+kill_gconf() {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+ return 0
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}