summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:28:13 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:28:13 +0000
commit8ce7f261ad0ec3eee3e031a6207d648f138caac1 (patch)
treec76e7e55d24199a6af555202e14e5f38da0c67d1 /x11-misc
parentversion bump (diff)
downloadgentoo-2-8ce7f261ad0ec3eee3e031a6207d648f138caac1.tar.gz
gentoo-2-8ce7f261ad0ec3eee3e031a6207d648f138caac1.tar.bz2
gentoo-2-8ce7f261ad0ec3eee3e031a6207d648f138caac1.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/magneto-gtk3/ChangeLog9
-rw-r--r--x11-misc/magneto-gtk3/magneto-gtk3-183.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/x11-misc/magneto-gtk3/ChangeLog b/x11-misc/magneto-gtk3/ChangeLog
index 2aacda65d995..44e248931775 100644
--- a/x11-misc/magneto-gtk3/ChangeLog
+++ b/x11-misc/magneto-gtk3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/magneto-gtk3
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk3/ChangeLog,v 1.4 2012/09/27 11:06:11 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk3/ChangeLog,v 1.5 2013/03/14 18:28:13 lxnay Exp $
+
+*magneto-gtk3-183 (14 Mar 2013)
+
+ 14 Mar 2013; Fabio Erculiani <lxnay@gentoo.org> +magneto-gtk3-183.ebuild:
+ version bump
*magneto-gtk3-144 (27 Sep 2012)
diff --git a/x11-misc/magneto-gtk3/magneto-gtk3-183.ebuild b/x11-misc/magneto-gtk3/magneto-gtk3-183.ebuild
new file mode 100644
index 000000000000..3fd1204d8acf
--- /dev/null
+++ b/x11-misc/magneto-gtk3/magneto-gtk3-183.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk3/magneto-gtk3-183.ebuild,v 1.1 2013/03/14 18:28:13 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet GTK3 frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ dev-libs/gobject-introspection
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-gtk3-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/gtk3"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/gtk3"
+}