summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-17 09:45:45 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-17 09:45:45 +0000
commit6c9d7d1a99fc481bd52972981faef1f9a4f2d75b (patch)
treed4fee2f059c833e24d82dd42c8cd5bc44deab01f /x11-misc/xvkbd
parentTake over maintainer ship (diff)
downloadgentoo-2-6c9d7d1a99fc481bd52972981faef1f9a4f2d75b.tar.gz
gentoo-2-6c9d7d1a99fc481bd52972981faef1f9a4f2d75b.tar.bz2
gentoo-2-6c9d7d1a99fc481bd52972981faef1f9a4f2d75b.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xvkbd')
-rw-r--r--x11-misc/xvkbd/ChangeLog10
-rw-r--r--x11-misc/xvkbd/files/xvkbd-3.6-last_altgr_mask.patch11
-rw-r--r--x11-misc/xvkbd/xvkbd-3.6.ebuild62
3 files changed, 81 insertions, 2 deletions
diff --git a/x11-misc/xvkbd/ChangeLog b/x11-misc/xvkbd/ChangeLog
index 098df6957513..b7613b37895e 100644
--- a/x11-misc/xvkbd/ChangeLog
+++ b/x11-misc/xvkbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xvkbd
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/ChangeLog,v 1.34 2014/09/18 18:24:52 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/ChangeLog,v 1.35 2015/02/17 09:45:45 jer Exp $
+
+*xvkbd-3.6 (17 Feb 2015)
+
+ 17 Feb 2015; Jeroen Roovers <jer@gentoo.org> +xvkbd-3.6.ebuild,
+ +files/xvkbd-3.6-last_altgr_mask.patch:
+ Version bump.
*xvkbd-3.5-r1 (18 Sep 2014)
diff --git a/x11-misc/xvkbd/files/xvkbd-3.6-last_altgr_mask.patch b/x11-misc/xvkbd/files/xvkbd-3.6-last_altgr_mask.patch
new file mode 100644
index 000000000000..7fe70773acca
--- /dev/null
+++ b/x11-misc/xvkbd/files/xvkbd-3.6-last_altgr_mask.patch
@@ -0,0 +1,11 @@
+--- a/xvkbd.c
++++ b/xvkbd.c
+@@ -681,7 +681,7 @@
+ }
+ }
+
+- last_altgr_mask = (altgr_mask | last_altgr_mask);
++ last_altgr_mask = altgr_mask;
+ alt_mask = 0;
+ meta_mask = 0;
+ altgr_mask = 0;
diff --git a/x11-misc/xvkbd/xvkbd-3.6.ebuild b/x11-misc/xvkbd/xvkbd-3.6.ebuild
new file mode 100644
index 000000000000..b12dd2939c30
--- /dev/null
+++ b/x11-misc/xvkbd/xvkbd-3.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/xvkbd-3.6.ebuild,v 1.1 2015/02/17 09:45:45 jer Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="virtual keyboard for X window system"
+HOMEPAGE="http://homepage3.nifty.com/tsato/xvkbd/"
+SRC_URI="http://homepage3.nifty.com/tsato/xvkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXaw3d
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-last_altgr_mask.patch
+
+ epatch_user
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) LD=$(tc-getCC) \
+ XAPPLOADDIR="/usr/share/X11/app-defaults" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake \
+ XAPPLOADDIR="/usr/share/X11/app-defaults" \
+ DESTDIR="${D}" \
+ install
+
+ rm -r "${D}"/usr/$(get_libdir) "${D}"/etc || die
+
+ dodoc README
+ newman ${PN}.man ${PN}.1
+}