summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-22 22:25:20 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-22 22:25:20 +0000
commit23c58d53ee3cd408e4dd66447f135e5cd3892ebd (patch)
treeead18ee5f05778c0f6b0f89244181ffe9d08e6f1 /x11-libs/qt-declarative
parentversion bump (diff)
downloadgentoo-2-23c58d53ee3cd408e4dd66447f135e5cd3892ebd.tar.gz
gentoo-2-23c58d53ee3cd408e4dd66447f135e5cd3892ebd.tar.bz2
gentoo-2-23c58d53ee3cd408e4dd66447f135e5cd3892ebd.zip
install qml imports, bug #346465
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-declarative')
-rw-r--r--x11-libs/qt-declarative/ChangeLog8
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.1-r1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index 3f722df17616..a64ea21451e5 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-declarative
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.13 2010/11/16 23:20:29 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.14 2010/11/22 22:25:19 wired Exp $
+
+*qt-declarative-4.7.1-r1 (22 Nov 2010)
+
+ 22 Nov 2010; Alex Alexander <wired@gentoo.org>
+ +qt-declarative-4.7.1-r1.ebuild:
+ install qml imports, bug #346465
16 Nov 2010; Alex Alexander <wired@gentoo.org>
qt-declarative-4.7.1.ebuild:
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.1-r1.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..1577a2c02057
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.1-r1.ebuild,v 1.1 2010/11/22 22:25:20 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="private-headers qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-opengl-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-script-${PV}[aqua=]
+ ~x11-libs/qt-sql-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-svg-${PV}[aqua=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=]
+ qt3support? ( ~x11-libs/qt-qt3support-${PV}[aqua=] )
+ "
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QCONFIG_ADD="declarative"
+
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ tools/qml"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -declarative $(qt_use qt3support)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}