summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:36:08 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:36:08 +0000
commit83f12a2fb40806d6f7590b40f156f2560a96e32b (patch)
tree48695391eee6b52531a1fba0e3d3c553e54391ce /x11-apps/xconsole
parentVersion bump. Includes a compile fix. (diff)
downloadgentoo-2-83f12a2fb40806d6f7590b40f156f2560a96e32b.tar.gz
gentoo-2-83f12a2fb40806d6f7590b40f156f2560a96e32b.tar.bz2
gentoo-2-83f12a2fb40806d6f7590b40f156f2560a96e32b.zip
Version bump. Avoids a possible underflow.
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-apps/xconsole')
-rw-r--r--x11-apps/xconsole/ChangeLog8
-rw-r--r--x11-apps/xconsole/files/digest-xconsole-1.0.23
-rw-r--r--x11-apps/xconsole/xconsole-1.0.2.ebuild22
3 files changed, 32 insertions, 1 deletions
diff --git a/x11-apps/xconsole/ChangeLog b/x11-apps/xconsole/ChangeLog
index 86e914dcbd6e..89fa0ff5233b 100644
--- a/x11-apps/xconsole/ChangeLog
+++ b/x11-apps/xconsole/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xconsole
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/ChangeLog,v 1.12 2006/02/14 21:03:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/ChangeLog,v 1.13 2006/04/29 16:36:07 joshuabaergen Exp $
+
+*xconsole-1.0.2 (29 Apr 2006)
+
+ 29 Apr 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xconsole-1.0.2.ebuild:
+ Version bump. Avoids a possible underflow.
14 Feb 2006; Markus Rothe <corsair@gentoo.org> xconsole-1.0.1.ebuild:
Added ~ppc64
diff --git a/x11-apps/xconsole/files/digest-xconsole-1.0.2 b/x11-apps/xconsole/files/digest-xconsole-1.0.2
new file mode 100644
index 000000000000..ae5aa92ffbe4
--- /dev/null
+++ b/x11-apps/xconsole/files/digest-xconsole-1.0.2
@@ -0,0 +1,3 @@
+MD5 8678ddd23573022d68dcd883ae239be8 xconsole-1.0.2.tar.bz2 86486
+RMD160 724bbcb99b7190d66a70bfe19e33cd36529dee2c xconsole-1.0.2.tar.bz2 86486
+SHA256 45db847e810a932bb962041a4c242f97779142f7e36feec64ec5f9073bd9b377 xconsole-1.0.2.tar.bz2 86486
diff --git a/x11-apps/xconsole/xconsole-1.0.2.ebuild b/x11-apps/xconsole/xconsole-1.0.2.ebuild
new file mode 100644
index 000000000000..0586b7ecc803
--- /dev/null
+++ b/x11-apps/xconsole/xconsole-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/xconsole-1.0.2.ebuild,v 1.1 2006/04/29 16:36:07 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xconsole application"
+KEYWORDS="~amd64 ~mips ~ppc64 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}