summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-12 06:15:43 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-12 06:15:43 +0000
commitec65ee2045eb89db895f8c817cefe864c67bd307 (patch)
tree560c4a656b292b46177b5e8c997f29fa447b05da /www-client/conkeror
parentFix alpha build issues in new alpha-mont.pl file #330915. (diff)
downloadgentoo-2-ec65ee2045eb89db895f8c817cefe864c67bd307.tar.gz
gentoo-2-ec65ee2045eb89db895f8c817cefe864c67bd307.tar.bz2
gentoo-2-ec65ee2045eb89db895f8c817cefe864c67bd307.zip
New snapshot, bug 333633.
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'www-client/conkeror')
-rw-r--r--www-client/conkeror/ChangeLog8
-rw-r--r--www-client/conkeror/conkeror-0.9.2_p20100830.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/www-client/conkeror/ChangeLog b/www-client/conkeror/ChangeLog
index c7f247b2dec7..a5906123a94c 100644
--- a/www-client/conkeror/ChangeLog
+++ b/www-client/conkeror/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/conkeror
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.14 2010/06/22 12:27:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.15 2010/09/12 06:15:43 ulm Exp $
+
+*conkeror-0.9.2_p20100830 (12 Sep 2010)
+
+ 12 Sep 2010; Ulrich Mueller <ulm@gentoo.org>
+ +conkeror-0.9.2_p20100830.ebuild:
+ New snapshot, bug 333633.
22 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
-conkeror-0.9.1.ebuild:
diff --git a/www-client/conkeror/conkeror-0.9.2_p20100830.ebuild b/www-client/conkeror/conkeror-0.9.2_p20100830.ebuild
new file mode 100644
index 000000000000..ec4e95f56aa6
--- /dev/null
+++ b/www-client/conkeror/conkeror-0.9.2_p20100830.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/conkeror-0.9.2_p20100830.ebuild,v 1.1 2010/09/12 06:15:43 ulm Exp $
+
+EAPI=3
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A Mozilla-based web browser whose design is inspired by GNU Emacs"
+HOMEPAGE="http://conkeror.org/"
+# snapshot from http://repo.or.cz/w/conkeror.git
+# conkeror.png is derived from http://commons.wikimedia.org/wiki/File:Conker.jpg
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/conkeror.png"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-libs/xulrunner-1.9"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}/conkeror.png" . || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ insinto /usr/lib/${PN}
+ doins -r branding chrome components content defaults help locale modules \
+ search-engines style tests || die
+ doins application.ini Info.plist || die
+
+ exeinto /usr/lib/${PN}
+ doexe conkeror-spawn-helper || die
+ exeinto /usr/lib/${PN}/contrib
+ doexe contrib/run-conkeror || die
+ dosym /usr/lib/${PN}/contrib/run-conkeror /usr/bin/conkeror || die
+ domenu "${FILESDIR}/conkeror.desktop" || die
+ doicon "${WORKDIR}/conkeror.png" || die
+
+ doman contrib/man/conkeror.1 || die
+ dodoc CREDITS || die
+ # Use the XULRunner found in the Prefix, not the system's one
+ sed -e "s:/etc/gre.d:\"${EPREFIX}/etc/gre.d\":g" -i "${ED}"/usr/lib/conkeror/contrib/run-conkeror || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}