summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-08-13 19:04:30 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-08-13 19:04:30 +0000
commitccf917c231637c7e3c4477d7b8a932590cb94fb2 (patch)
treee56f984a14256634e96fe20ddc77e044dc5a9f9e /www-apps
parentNew snapshot. Make SDL entirely optional, and split GUI and sound flags, bug ... (diff)
downloadgentoo-2-ccf917c231637c7e3c4477d7b8a932590cb94fb2.tar.gz
gentoo-2-ccf917c231637c7e3c4477d7b8a932590cb94fb2.tar.bz2
gentoo-2-ccf917c231637c7e3c4477d7b8a932590cb94fb2.zip
Ported to EAPI 2 USE deps. Bug #332165
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/moodle/ChangeLog8
-rw-r--r--www-apps/moodle/files/postinstall-en.txt8
-rw-r--r--www-apps/moodle/moodle-1.9.9-r1.ebuild121
3 files changed, 134 insertions, 3 deletions
diff --git a/www-apps/moodle/ChangeLog b/www-apps/moodle/ChangeLog
index cc9c86ec7d99..fe7e799efb47 100644
--- a/www-apps/moodle/ChangeLog
+++ b/www-apps/moodle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/moodle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.1 2010/07/19 14:05:32 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.2 2010/08/13 19:04:30 blueness Exp $
+
+*moodle-1.9.9-r1 (13 Aug 2010)
+
+ 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
+ +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
+ Ported to EAPI 2 USE deps. Bug #332165
*moodle-1.9.9 (19 Jul 2010)
diff --git a/www-apps/moodle/files/postinstall-en.txt b/www-apps/moodle/files/postinstall-en.txt
index 5fe772f27e38..c46bfcc25eb4 100644
--- a/www-apps/moodle/files/postinstall-en.txt
+++ b/www-apps/moodle/files/postinstall-en.txt
@@ -5,7 +5,9 @@ NEW INSTALLS
see a directory in there called moodle. If it didn't
install it manually:
- webapp-config -d moodle -I moodle 1.9.9
+ webapp-config -d moodle -I moodle X.Y.Z
+
+ Replace X.Y.Z with whatever version you just emerged.
1 Edit the config.php file found at
@@ -49,7 +51,9 @@ NEW INSTALLS
psql -c "create database moodle_db with encoding 'unicode';" -U moodle_user template1
psql -c "alter user moodle_user nocreatedb;" template1
su - root
- /etc/init.d/postgresql-8.4 reload
+ /etc/init.d/postgresql-X.Y reload
+
+ Replace X.Y with your version postgresql.
NOTE: Moodle docs say that moodle only works with
postgresql-7, but I've used it with 8 no problems.
diff --git a/www-apps/moodle/moodle-1.9.9-r1.ebuild b/www-apps/moodle/moodle-1.9.9-r1.ebuild
new file mode 100644
index 000000000000..2265cc72b499
--- /dev/null
+++ b/www-apps/moodle/moodle-1.9.9-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-1.9.9-r1.ebuild,v 1.1 2010/08/13 19:04:30 blueness Exp $
+
+EAPI="2"
+
+inherit versionator webapp
+
+AVC=( $(get_version_components) )
+MY_BRANCH="stable${AVC[0]}${AVC[1]}"
+
+DESCRIPTION="The Moodle Course Management System"
+HOMEPAGE="http://moodle.org"
+SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+#SLOT empty due to webapp
+
+DBFLAGS="mysql?,postgres?"
+DBTYPES=${DBFLAGS//\?/}
+DBTYPES=${DBTYPES//,/ }
+
+AUTHFLAGS="imap?,ldap?,odbc?"
+AUTHMODES=${AUTHFLAGS//\?/}
+AUTHMODES=${AUTHMODES//,/ }
+
+PHPFLAGS="ctype,curl,gd,iconv,ssl,tokenizer,xml,xmlrpc,zlib"
+
+IUSE="${DBTYPES} ${AUTHMODES} vhosts"
+
+# No forced dependency on
+# mysql? ( virtual/mysql )
+# postgres? ( dev-db/postgresql-server-7* )
+# which may live on another server
+DEPEND=""
+RDEPEND=">=dev-lang/php-4.3.0[${DBFLAGS},${AUTHFLAGS},${PHPFLAGS}]
+ virtual/httpd-php
+ virtual/cron"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ # How many dbs were selected? If one and only one, which one is it?
+ MYDB=""
+ DBCOUNT=0
+ for db in ${DBTYPES}; do
+ if use ${db}; then
+ MYDB=${db}
+ DBCOUNT=$(($DBCOUNT+1))
+ fi
+ done
+
+ if [[ ${DBCOUNT} -eq 0 ]]; then
+ eerror
+ eerror "\033[1;31m**************************************************\033[1;31m"
+ eerror "No database selected in your USE flags,"
+ eerror "You must select at least one."
+ eerror "\033[1;31m**************************************************\033[1;31m"
+ eerror
+ die
+ fi
+
+ if [[ ${DBCOUNT} -gt 1 ]]; then
+ MYDB=""
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[1;33m"
+ ewarn "Multiple databases selected in your USE flags,"
+ ewarn "You will have to choose your database manually."
+ ewarn "\033[1;33m**************************************************\033[1;33m"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ rm COPYING.txt
+ cp "${FILESDIR}"/config.php .
+
+ #
+ # Moodle expect postgres7, not postgres
+ #
+ MYDB=${MYDB/postgres/postgres7}
+ if [[ ${DBCOUNT} -eq 1 ]] ; then
+ sed -i -e "s|mydb|${MYDB}|" config.php
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
+ dodir ${MOODLEDATA}
+ webapp_serverowned -R "${MOODLEDATA}"
+
+ local MOODLEROOT="${MY_HTDOCSDIR}"
+ insinto ${MOODLEROOT} || die "Unable to insinto ${MOODLEROOT}"
+ doins -r *
+
+ webapp_configfile "${MOODLEROOT}"/config.php
+
+ if [[ ${DBCOUNT} -eq 1 ]]; then
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
+ fi
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "\033[1;32m**************************************************\033[1;32m"
+ einfo
+ einfo "To see the post install instructions, do"
+ einfo
+ einfo " webapp-config --show-postinst ${PN} ${PVR}"
+ einfo
+ einfo "\033[1;32m**************************************************\033[1;32m"
+ einfo
+}