summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-31 04:25:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-31 04:25:08 +0000
commitae6497a48cd6dcc17fb6ffb30bbf037e8f955cb7 (patch)
tree1e380d1632c5e39464c2980b31e7719f1b953a23 /sys-libs/gpm
parentInitial import of QtScrobbler - a last.fm committer for portable devices (diff)
downloadgentoo-2-ae6497a48cd6dcc17fb6ffb30bbf037e8f955cb7.tar.gz
gentoo-2-ae6497a48cd6dcc17fb6ffb30bbf037e8f955cb7.tar.bz2
gentoo-2-ae6497a48cd6dcc17fb6ffb30bbf037e8f955cb7.zip
Version bump.
(Portage version: 2.2_pre5.spank.spunk)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog7
-rw-r--r--sys-libs/gpm/gpm-1.20.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index c80810def662..5906ae0474bd 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.66 2008/04/21 07:08:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.67 2008/05/31 04:25:08 vapier Exp $
+
+*gpm-1.20.4 (31 May 2008)
+
+ 31 May 2008; Mike Frysinger <vapier@gentoo.org> +gpm-1.20.4.ebuild:
+ Version bump.
21 Apr 2008; Ulrich Mueller <ulm@gentoo.org>
+files/gpm-1.20.3-no-emacs-dir.patch, gpm-1.20.3.ebuild:
diff --git a/sys-libs/gpm/gpm-1.20.4.ebuild b/sys-libs/gpm/gpm-1.20.4.ebuild
new file mode 100644
index 000000000000..26de7b1e41de
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.4.ebuild,v 1.1 2008/05/31 04:25:08 vapier Exp $
+
+# emacs support disabled due to Bug 99533
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://linux.schottelius.org/gpm/"
+SRC_URI="http://linux.schottelius.org/gpm/archives/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+# need to sort out SONAME first
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="sys-libs/ncurses
+ app-arch/lzma-utils"
+RDEPEND="selinux? ( sec-policy/selinux-gpm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20.3-no-emacs-dir.patch
+}
+
+src_compile() {
+ econf \
+ --libdir=/$(get_libdir) \
+ --sysconfdir=/etc/gpm \
+ || die "econf failed"
+
+ # workaround broken release
+ find -name '*.o' | xargs rm
+ emake clean || die
+ emake -j1 -C doc || die
+
+ emake EMACS=: || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
+
+ dosym libgpm.so.1.20.0 /$(get_libdir)/libgpm.so.1
+ dosym libgpm.so.1 /$(get_libdir)/libgpm.so
+ dodir /usr/$(get_libdir)
+ mv "${D}"/$(get_libdir)/libgpm.a "${D}"/usr/$(get_libdir)/ || die
+ gen_usr_ldscript libgpm.so
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc BUGS Changes README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+}