summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-07-13 07:46:17 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-07-13 07:46:17 +0000
commit95a0ed5ba7b1f9a060398f9a58e22450dc79a914 (patch)
tree56340b3264e85efb2bd9b9043b865bde6214a555 /sys-kernel/ck-sources
parentPython patches and fix for implicit declaration (gone upstream) (diff)
downloadgentoo-2-95a0ed5ba7b1f9a060398f9a58e22450dc79a914.tar.gz
gentoo-2-95a0ed5ba7b1f9a060398f9a58e22450dc79a914.tar.bz2
gentoo-2-95a0ed5ba7b1f9a060398f9a58e22450dc79a914.zip
Revision bump for new genpatches.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog8
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.34-r2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index ade7bef57a99..f29b4403f69b 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.174 2010/06/23 19:17:33 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.175 2010/07/13 07:46:17 nelchael Exp $
+
+*ck-sources-2.6.34-r2 (13 Jul 2010)
+
+ 13 Jul 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.34-r2.ebuild:
+ Revision bump for new genpatches.
*ck-sources-2.6.34-r1 (23 Jun 2010)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.34-r2.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.34-r2.ebuild
new file mode 100644
index 000000000000..05093c0e892b
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.34-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.34-r2.ebuild,v 1.1 2010/07/13 07:46:17 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="4"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}