summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-08 16:29:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-08 16:29:26 +0000
commitf2c90e20d0b32e80fd2b3833206146ea3b1c48e5 (patch)
tree0ce9da004a23a6c01aef295ca6cc8601a2bd803f /sys-fs/clamfs
parentVersion bump (diff)
downloadgentoo-2-f2c90e20d0b32e80fd2b3833206146ea3b1c48e5.tar.gz
gentoo-2-f2c90e20d0b32e80fd2b3833206146ea3b1c48e5.tar.bz2
gentoo-2-f2c90e20d0b32e80fd2b3833206146ea3b1c48e5.zip
Initial import, bug #259863.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/clamfs')
-rw-r--r--sys-fs/clamfs/ChangeLog11
-rw-r--r--sys-fs/clamfs/clamfs-1.0.1.ebuild41
-rw-r--r--sys-fs/clamfs/files/clamfs-1.0.1-gentoo.patch12
-rw-r--r--sys-fs/clamfs/files/clamfs.confd1
-rw-r--r--sys-fs/clamfs/files/clamfs.initd22
-rw-r--r--sys-fs/clamfs/metadata.xml14
6 files changed, 101 insertions, 0 deletions
diff --git a/sys-fs/clamfs/ChangeLog b/sys-fs/clamfs/ChangeLog
new file mode 100644
index 000000000000..cb7cd56bd248
--- /dev/null
+++ b/sys-fs/clamfs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/clamfs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/ChangeLog,v 1.1 2010/01/08 16:29:26 matsuu Exp $
+
+*clamfs-1.0.1 (08 Jan 2010)
+
+ 08 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> +clamfs-1.0.1.ebuild,
+ +files/clamfs-1.0.1-gentoo.patch, +files/clamfs.confd,
+ +files/clamfs.initd, +metadata.xml:
+ Initial import, bug #259863.
+
diff --git a/sys-fs/clamfs/clamfs-1.0.1.ebuild b/sys-fs/clamfs/clamfs-1.0.1.ebuild
new file mode 100644
index 000000000000..80fd6566e603
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/clamfs-1.0.1.ebuild,v 1.1 2010/01/08 16:29:26 matsuu Exp $
+
+EAPI="2"
+inherit eutils linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="http://clamfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33
+ sys-fs/fuse
+ dev-cpp/commoncpp2
+ dev-libs/rlog
+ dev-libs/poco"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}
diff --git a/sys-fs/clamfs/files/clamfs-1.0.1-gentoo.patch b/sys-fs/clamfs/files/clamfs-1.0.1-gentoo.patch
new file mode 100644
index 000000000000..f5c02daca6d6
--- /dev/null
+++ b/sys-fs/clamfs/files/clamfs-1.0.1-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur clamfs-1.0.1.orig/doc/clamfs.xml clamfs-1.0.1/doc/clamfs.xml
+--- clamfs-1.0.1.orig/doc/clamfs.xml 2009-02-07 23:09:26.000000000 +0900
++++ clamfs-1.0.1/doc/clamfs.xml 2010-01-08 18:19:13.000000000 +0900
+@@ -16,7 +16,7 @@
+ check - (yes or no) check if clamd is available on startup (useful if
+ mounting clamfs file systems from /etc/fstab early on startup,
+ while clamav daemon is not yet started) -->
+- <clamd socket="/var/run/clamav/clamd.ctl" check="yes" />
++ <clamd socket="/var/run/clamav/clamd.sock" check="yes" />
+
+ <!-- File system settings
+ root - real directory to attach as our root
diff --git a/sys-fs/clamfs/files/clamfs.confd b/sys-fs/clamfs/files/clamfs.confd
new file mode 100644
index 000000000000..941549a4ca60
--- /dev/null
+++ b/sys-fs/clamfs/files/clamfs.confd
@@ -0,0 +1 @@
+CLAMFS_CONFFILE="/etc/clamfs/clamfs.xml"
diff --git a/sys-fs/clamfs/files/clamfs.initd b/sys-fs/clamfs/files/clamfs.initd
new file mode 100644
index 000000000000..2a9d3e2fdb50
--- /dev/null
+++ b/sys-fs/clamfs/files/clamfs.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/files/clamfs.initd,v 1.1 2010/01/08 16:29:25 matsuu Exp $
+
+depend() {
+ use logger
+ need clamd
+}
+
+start() {
+ ebegin "Starting clamfs"
+ start-stop-daemon --start --quiet \
+ --exec /usr/bin/clamfs -- ${CLAMFS_CONFFILE}
+ eend $? "Failed to start clamfs"
+}
+
+stop() {
+ ebegin "Stopping clamfs"
+ start-stop-daemon --stop --quiet --name clamfs
+ eend $? "Failed to stop clamfs"
+}
diff --git a/sys-fs/clamfs/metadata.xml b/sys-fs/clamfs/metadata.xml
new file mode 100644
index 000000000000..bbca447d50e7
--- /dev/null
+++ b/sys-fs/clamfs/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ ClamFS is a FUSE-based user-space file system for Linux with on-access
+ anti-virus file scanning through clamd daemon (a file scanning service
+ developed by ClamAV Project).
+</longdescription>
+</pkgmetadata>
+