summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-11 16:52:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-11 16:52:28 +0000
commitfdfc0d55c45812d18afd35969d2f9b3901c11e5e (patch)
treeda16ffcce9155a300c18dffd238040b53325ce7c /sys-freebsd
parentbump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838 (diff)
downloadgentoo-2-fdfc0d55c45812d18afd35969d2f9b3901c11e5e.tar.gz
gentoo-2-fdfc0d55c45812d18afd35969d2f9b3901c11e5e.tar.bz2
gentoo-2-fdfc0d55c45812d18afd35969d2f9b3901c11e5e.zip
bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-libexec/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-9.1_rc1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-libexec/ChangeLog b/sys-freebsd/freebsd-libexec/ChangeLog
index c74b3187b2ac..de99f5c17255 100644
--- a/sys-freebsd/freebsd-libexec/ChangeLog
+++ b/sys-freebsd/freebsd-libexec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-libexec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.48 2012/04/26 14:20:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.49 2012/09/11 16:52:28 aballier Exp $
+
+*freebsd-libexec-9.1_rc1 (11 Sep 2012)
+
+ 11 Sep 2012; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-libexec-9.1_rc1.ebuild:
+ bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> freebsd-libexec-9.0.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-9.1_rc1.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-9.1_rc1.ebuild
new file mode 100644
index 000000000000..a553fa709ac2
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/freebsd-libexec-9.1_rc1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-9.1_rc1.ebuild,v 1.1 2012/09/11 16:52:28 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd pam
+
+DESCRIPTION="FreeBSD libexec things"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+
+SRC_URI="mirror://gentoo/${LIBEXEC}.tar.bz2
+ mirror://gentoo/${UBIN}.tar.bz2
+ mirror://gentoo/${BIN}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${ETC}.tar.bz2
+ mirror://gentoo/${USBIN}.tar.bz2"
+
+RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ =sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-sources-${RV}*"
+RDEPEND="${RDEPEND}
+ xinetd? ( sys-apps/xinetd )"
+
+S="${WORKDIR}/libexec"
+
+# Remove sendmail, tcp_wrapper and other useless stuff
+REMOVE_SUBDIRS="smrsh mail.local tcpd telnetd rshd rlogind lukemftpd ftpd"
+
+IUSE="pam ssl kerberos ipv6 nis xinetd"
+
+pkg_setup() {
+ use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6= WITHOUT_INET6_SUPPORT= "
+ use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= "
+ use nis || mymakeopts="${mymakeopts} WITHOUT_NIS= "
+ use pam || mymakeopts="${mymakeopts} WITHOUT_PAM_SUPPORT= "
+ use ssl || mymakeopts="${mymakeopts} WITHOUT_OPENSSL= "
+
+ mymakeopts="${mymakeopts} WITHOUT_SENDMAIL= WITHOUT_PF= WITHOUT_RCMDS= "
+}
+
+src_prepare() {
+ ln -s /usr/include "${WORKDIR}/include"
+}
+
+src_install() {
+ freebsd_src_install
+
+ insinto /etc
+ doins "${WORKDIR}/etc/gettytab"
+ newinitd "${FILESDIR}/bootpd.initd" bootpd
+ newconfd "${FILESDIR}/bootpd.confd" bootpd
+
+ if use xinetd; then
+ for rpcd in rstatd rusersd walld rquotad sprayd; do
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/${rpcd}.xinetd" ${rpcd}
+ done
+ fi
+}