summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-09-04 14:50:46 +0000
committerRoy Marples <uberlord@gentoo.org>2007-09-04 14:50:46 +0000
commitee20098a35c58fa47fb394deb7ff34f1d0baa0ed (patch)
treee32bb2b5bc4e5d10bbd92bc2a3a7c333ca3af5d0 /sys-freebsd
parentVersion bump (#190751) and homepage update. (diff)
downloadgentoo-2-ee20098a35c58fa47fb394deb7ff34f1d0baa0ed.tar.gz
gentoo-2-ee20098a35c58fa47fb394deb7ff34f1d0baa0ed.tar.bz2
gentoo-2-ee20098a35c58fa47fb394deb7ff34f1d0baa0ed.zip
Patch make so the sinclude directive works.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-ubin/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-make-sinclude.patch60
-rw-r--r--sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild3
3 files changed, 67 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-ubin/ChangeLog b/sys-freebsd/freebsd-ubin/ChangeLog
index b185bcc87eeb..a8bd77c053a0 100644
--- a/sys-freebsd/freebsd-ubin/ChangeLog
+++ b/sys-freebsd/freebsd-ubin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-ubin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.47 2007/09/03 14:49:36 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.48 2007/09/04 14:50:45 uberlord Exp $
+
+ 04 Sep 2007; Roy Marples <uberlord@gentoo.org>
+ +files/freebsd-ubin-6.2-make-sinclude.patch, freebsd-ubin-6.2.ebuild:
+ Patch make so the sinclude directive works.
03 Sep 2007; Roy Marples <uberlord@gentoo.org> freebsd-ubin-6.2.ebuild:
Move touch back to /usr/bin as baselayout no longer uses it.
diff --git a/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-make-sinclude.patch b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-make-sinclude.patch
new file mode 100644
index 000000000000..73256172fff0
--- /dev/null
+++ b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-make-sinclude.patch
@@ -0,0 +1,60 @@
+--- usr.bin/make/parse.c.orig 2007-09-04 14:39:07 +0100
++++ usr.bin/make/parse.c 2007-09-04 14:51:00 +0100
+@@ -1602,8 +1602,8 @@
+ * ParseTraditionalInclude --
+ * Push to another file.
+ *
+- * The input is the line minus the "include". The file name is
+- * the string following the "include".
++ * The input is the current line. The file name(s) are
++ * following the "include".
+ *
+ * Results:
+ * None
+@@ -1614,10 +1614,12 @@
+ *---------------------------------------------------------------------
+ */
+ static void
+-ParseTraditionalInclude(char *file)
++ParseTraditionalInclude(char *line)
+ {
+ char *fullname; /* full pathname of file */
+ char *cp; /* current position in file spec */
++ int silent = (line[0] != 'i') ? 1 : 0;
++ char *file = &line[silent + 7];
+
+ /*
+ * Skip over whitespace
+@@ -1665,7 +1667,9 @@
+ }
+
+ if (fullname == NULL) {
+- Parse_Error(PARSE_FATAL, "Could not find %s", file);
++ if (!silent) {
++ Parse_Error(PARSE_FATAL, "Could not find %s", file);
++ }
+ /* XXXHB free(file) */
+ return;
+ }
+@@ -2416,14 +2420,16 @@
+ }
+ }
+ #ifdef SYSVINCLUDE
+- } else if (strncmp(line, "include", 7) == 0 &&
+- isspace((unsigned char)line[7]) &&
+- strchr(line, ':') == NULL) {
++ } else if (((strncmp(line, "include", 7) == 0 &&
++ isspace((unsigned char) line[7])) ||
++ ((line[0] == 's' || line[0] == '-') &&
++ strncmp(&line[1], "include", 7) == 0 &&
++ isspace((unsigned char) line[8]))) &&
++ strchr(line, ':') == NULL) {
+ /*
+ * It's an S3/S5-style "include".
+ */
+- ParseTraditionalInclude(line + 7);
+- goto nextLine;
++ ParseTraditionalInclude(line);
+ #endif
+ } else if (Parse_IsVar(line)) {
+ ParseFinishLine();
diff --git a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild
index a5b15ba8fb3e..1e2b66ebd628 100644
--- a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild
+++ b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild,v 1.4 2007/09/03 14:49:36 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2.ebuild,v 1.5 2007/09/04 14:50:45 uberlord Exp $
inherit bsdmk freebsd flag-o-matic pam
@@ -55,6 +55,7 @@ PATCHES="${FILESDIR}/${PN}-6.0-bsdcmp.patch
${FILESDIR}/${PN}-lint-stdarg.patch
${FILESDIR}/${PN}-6.0-kdump-ioctl.patch
${FILESDIR}/${PN}-6.1-gcc41.patch
+ ${FILESDIR}/${PN}-6.2-make-sinclude.patch
${FILESDIR}/${PN}-6.2-rpcgen-gcc4.1.patch
${FILESDIR}/${PN}-6.2-sparc64.patch"