summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-12-23 21:36:09 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-12-23 21:36:09 +0000
commitb8f3299e794f0957aaaa56429d52c98842b6c9b9 (patch)
treed4fac92e43ae15b8a220fafbb260c4be6e5fc314 /sys-devel/gcc
parentfix build with +server wrt #494362 (diff)
downloadgentoo-2-b8f3299e794f0957aaaa56429d52c98842b6c9b9.tar.gz
gentoo-2-b8f3299e794f0957aaaa56429d52c98842b6c9b9.tar.bz2
gentoo-2-b8f3299e794f0957aaaa56429d52c98842b6c9b9.zip
4.8.2 p1.1: Fix segfault with std::nth_element (bug #494796) and build
failures in gcj due to freetype include dir changes (bug #494606). Rename gtk USE flag to awt. Remove lto USE flag. Remove messages. Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog10
-rw-r--r--sys-devel/gcc/gcc-4.6.0.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.6.1-r1.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.6.2.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.6.3.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.6.4.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.7.0.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.7.1.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.7.2-r1.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.7.3-r1.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.8.0.ebuild23
-rw-r--r--sys-devel/gcc/gcc-4.8.1-r1.ebuild23
-rw-r--r--sys-devel/gcc/gcc-4.8.2.ebuild20
-rw-r--r--sys-devel/gcc/metadata.xml6
14 files changed, 24 insertions, 175 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 3c091ae5f4e1..7e3145a48ea0 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.984 2013/12/23 19:42:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.985 2013/12/23 21:36:09 dirtyepic Exp $
+
+ 23 Dec 2013; Ryan Hill <dirtyepic@gentoo.org> gcc-4.6.0.ebuild,
+ gcc-4.6.1-r1.ebuild, gcc-4.6.2.ebuild, gcc-4.6.3.ebuild, gcc-4.6.4.ebuild,
+ gcc-4.7.0.ebuild, gcc-4.7.1.ebuild, gcc-4.7.2-r1.ebuild, gcc-4.7.3-r1.ebuild,
+ gcc-4.8.0.ebuild, gcc-4.8.1-r1.ebuild, gcc-4.8.2.ebuild, metadata.xml:
+ 4.8.2 p1.1: Fix segfault with std::nth_element (bug #494796) and build
+ failures in gcj due to freetype include dir changes (bug #494606). Rename gtk
+ USE flag to awt. Remove lto USE flag. Remove messages.
23 Dec 2013; Mike Frysinger <vapier@gentoo.org> gcc-4.7.3-r1.ebuild:
Mark ia64 stable #467274.
diff --git a/sys-devel/gcc/gcc-4.6.0.ebuild b/sys-devel/gcc/gcc-4.6.0.ebuild
index bb3526307b34..b983cb82d980 100644
--- a/sys-devel/gcc/gcc-4.6.0.ebuild
+++ b/sys-devel/gcc/gcc-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.14 2013/05/15 02:43:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.15 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -45,14 +45,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.6.1-r1.ebuild b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
index b4ca758fa75b..179cc5d0c5fe 100644
--- a/sys-devel/gcc/gcc-4.6.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.1-r1.ebuild,v 1.11 2013/05/15 02:43:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.1-r1.ebuild,v 1.12 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -46,14 +46,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.6.2.ebuild b/sys-devel/gcc/gcc-4.6.2.ebuild
index fb15447a4759..8df1861de2f3 100644
--- a/sys-devel/gcc/gcc-4.6.2.ebuild
+++ b/sys-devel/gcc/gcc-4.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.16 2013/05/15 02:43:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.17 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.5"
UCLIBC_VER="1.0"
@@ -49,14 +49,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.6.3.ebuild b/sys-devel/gcc/gcc-4.6.3.ebuild
index 4b6c05232335..13b9225e22a5 100644
--- a/sys-devel/gcc/gcc-4.6.3.ebuild
+++ b/sys-devel/gcc/gcc-4.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.3.ebuild,v 1.38 2013/10/05 04:08:32 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.3.ebuild,v 1.39 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.13"
UCLIBC_VER="1.0"
@@ -47,14 +47,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.6.4.ebuild b/sys-devel/gcc/gcc-4.6.4.ebuild
index fc3716b7c5c7..00904f133003 100644
--- a/sys-devel/gcc/gcc-4.6.4.ebuild
+++ b/sys-devel/gcc/gcc-4.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.4.ebuild,v 1.2 2013/05/15 02:43:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.4.ebuild,v 1.3 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -47,14 +47,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.7.0.ebuild b/sys-devel/gcc/gcc-4.7.0.ebuild
index 85dd5e36b6b6..19e5e3e4f63d 100644
--- a/sys-devel/gcc/gcc-4.7.0.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.10 2013/05/20 10:56:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.11 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.2"
UCLIBC_VER="1.0"
@@ -52,14 +52,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.7.1.ebuild b/sys-devel/gcc/gcc-4.7.1.ebuild
index e20b4d48615e..a237da51d1cf 100644
--- a/sys-devel/gcc/gcc-4.7.1.ebuild
+++ b/sys-devel/gcc/gcc-4.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.1.ebuild,v 1.11 2013/05/20 10:56:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.1.ebuild,v 1.12 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.5"
UCLIBC_VER="1.0"
@@ -52,14 +52,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.7.2-r1.ebuild b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
index f1c2d0b8ed81..f68757b2c3b9 100644
--- a/sys-devel/gcc/gcc-4.7.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.2-r1.ebuild,v 1.6 2013/05/20 10:56:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.2-r1.ebuild,v 1.7 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.6"
UCLIBC_VER="1.0"
@@ -53,14 +53,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.7.3-r1.ebuild b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
index 566c231b5677..1e3331b4a57a 100644
--- a/sys-devel/gcc/gcc-4.7.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.3-r1.ebuild,v 1.12 2013/12/23 19:42:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.3-r1.ebuild,v 1.13 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -53,14 +53,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable."
- ewarn "Any bugs resulting from the use of LTO will not be fixed."
- ewarn
- fi
-}
diff --git a/sys-devel/gcc/gcc-4.8.0.ebuild b/sys-devel/gcc/gcc-4.8.0.ebuild
index a9fda0be9c04..1a2f3aba089b 100644
--- a/sys-devel/gcc/gcc-4.8.0.ebuild
+++ b/sys-devel/gcc/gcc-4.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.0.ebuild,v 1.10 2013/11/07 03:29:24 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.0.ebuild,v 1.11 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -48,24 +48,3 @@ src_unpack() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable. Any bug reports"
- ewarn "about LTO that do not include an upstream patch will be closed as"
- ewarn "invalid."
- ewarn
- fi
-}
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- elog
- elog "Packages failing to build with GCC 4.8 are tracked at"
- elog "https://bugs.gentoo.org/461954"
- elog
-}
diff --git a/sys-devel/gcc/gcc-4.8.1-r1.ebuild b/sys-devel/gcc/gcc-4.8.1-r1.ebuild
index 4b1ac2dc0716..29c5636645ae 100644
--- a/sys-devel/gcc/gcc-4.8.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.1-r1.ebuild,v 1.8 2013/11/04 02:29:58 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.1-r1.ebuild,v 1.9 2013/12/23 21:36:09 dirtyepic Exp $
PATCH_VER="1.2"
UCLIBC_VER="1.0"
@@ -48,24 +48,3 @@ src_unpack() {
#Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable. Any bug reports"
- ewarn "about LTO that do not include an upstream patch will be closed as"
- ewarn "invalid."
- ewarn
- fi
-}
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- elog
- elog "Packages failing to build with GCC 4.8 are tracked at"
- elog "https://bugs.gentoo.org/461954"
- elog
-}
diff --git a/sys-devel/gcc/gcc-4.8.2.ebuild b/sys-devel/gcc/gcc-4.8.2.ebuild
index 9be324f3571d..55e659c0e0cf 100644
--- a/sys-devel/gcc/gcc-4.8.2.ebuild
+++ b/sys-devel/gcc/gcc-4.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.2.ebuild,v 1.1 2013/11/11 23:38:10 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.2.ebuild,v 1.2 2013/12/23 21:36:09 dirtyepic Exp $
-PATCH_VER="1.0"
+PATCH_VER="1.1"
UCLIBC_VER="1.0"
# Hardened gcc 4 stuff
@@ -48,19 +48,3 @@ src_unpack() {
#Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
}
-
-pkg_setup() {
- toolchain_pkg_setup
-
- if use lto ; then
- ewarn
- ewarn "LTO support is still experimental and unstable. Any bug reports"
- ewarn "about LTO that do not include an upstream patch will be closed as"
- ewarn "invalid."
- ewarn
- fi
-}
-
-pkg_postinst() {
- toolchain_pkg_postinst
-}
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index a595b1856bfd..cc0d5da0514c 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -3,22 +3,20 @@
<pkgmetadata>
<herd>toolchain</herd>
<use>
+ <flag name="awt">Useful only when building GCJ, this enables Abstract Window Toolkit
+ (AWT) peer support on top of GTK+</flag>
<flag name="d">Enable support for the D programming language</flag>
<flag name="fixed-point">Enable fixed-point arithmetic support for MIPS targets
in gcc (Warning: significantly increases compile time!)</flag>
<flag name="go">Build the GCC Go language frontend.</flag>
<flag name="graphite">Add support for the framework for loop
optimizations based on a polyhedral intermediate representation</flag>
- <flag name="gtk">Useful only when building GCJ, this enables Abstract Window Toolkit
- (AWT) peer support on top of GTK+</flag>
<flag name="ip28">Enable building a compiler capable of building a kernel
for SGI Indigo2 Impact R10000 (IP28)</flag>
<flag name="ip32r10k">Enable building a compiler capable of building an
experimental kernel for SGI O2 w/ R1x000 CPUs (IP32)</flag>
<flag name="libssp">Build SSP support into a dedicated library rather than use the
code in the C library (DO NOT ENABLE THIS IF YOU DON'T KNOW WHAT IT DOES)</flag>
- <flag name="lto">Add support for link-time optimizations (unsupported, use
- at your own risk).</flag>
<flag name="mudflap">Add support for mudflap, a pointer use checking library</flag>
<flag name="multislot">Allow for SLOTs to include minor version (3.3.4
instead of just 3.3)</flag>