summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-09 17:03:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-09 17:03:02 +0000
commitacef74dde205783c8395a6b5adda5025bd278443 (patch)
treebef77f50942c088c5094af7d2533acef83b830a7 /sys-auth
parentAdd ~ia64 wrt #338289 (diff)
downloadgentoo-2-acef74dde205783c8395a6b5adda5025bd278443.tar.gz
gentoo-2-acef74dde205783c8395a6b5adda5025bd278443.tar.bz2
gentoo-2-acef74dde205783c8395a6b5adda5025bd278443.zip
Revert prev. commit, PDEPEND is really required here.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog5
-rw-r--r--sys-auth/polkit/polkit-0.99.ebuild26
2 files changed, 16 insertions, 15 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 5e0b7dc995ed..420e817580cb 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,9 +1,6 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.28 2010/10/08 00:04:53 ssuominen Exp $
-
- 08 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99.ebuild:
- Stop PDEPEND abuse and clean up in general.
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.29 2010/10/09 17:03:02 ssuominen Exp $
*polkit-0.99 (25 Sep 2010)
diff --git a/sys-auth/polkit/polkit-0.99.ebuild b/sys-auth/polkit/polkit-0.99.ebuild
index 00f7e7edfb49..753d34329b55 100644
--- a/sys-auth/polkit/polkit-0.99.ebuild
+++ b/sys-auth/polkit/polkit-0.99.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.99.ebuild,v 1.2 2010/10/08 00:04:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.99.ebuild,v 1.3 2010/10/09 17:02:54 ssuominen Exp $
-EAPI=2
-inherit eutils multilib pam
+EAPI="2"
+
+inherit autotools eutils multilib pam
DESCRIPTION="Policy framework for controlling privileges for system-wide services"
HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit"
@@ -14,21 +15,23 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples +introspection nls pam"
-COMMON_DEPEND=">=dev-libs/glib-2.25.12
+# not mature enough
+RDEPEND=">=dev-libs/glib-2.25.12
dev-libs/expat
introspection? ( dev-libs/gobject-introspection )
pam? ( virtual/pam )"
-RDEPEND="${COMMON_DEPEND}
- >=sys-auth/consolekit-0.4[policykit]"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
+ !!>=sys-auth/policykit-0.92
dev-libs/libxslt
app-text/docbook-xsl-stylesheets
>=dev-util/pkgconfig-0.18
>=dev-util/intltool-0.36
doc? ( >=dev-util/gtk-doc-1.13 )"
+PDEPEND=">=sys-auth/consolekit-0.4[policykit]"
+# gtk-doc-am-1.13 needed for eautoreconf
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.96-getcwd.patch
+ epatch "${FILESDIR}/${PN}-0.96-getcwd.patch"
}
src_configure() {
@@ -60,8 +63,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc NEWS README AUTHORS ChangeLog || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc NEWS README AUTHORS ChangeLog || die "dodoc failed"
# We disable example compilation above, and handle it here
if use examples; then
@@ -69,7 +73,7 @@ src_install() {
doins src/examples/{*.c,*.policy*}
fi
- # Need to keep a few directories around.
+ # Need to keep a few directories around...
diropts -m0700 -o root -g root
keepdir /var/run/polkit-1
keepdir /var/lib/polkit-1