summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-09-12 21:45:26 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-09-12 21:45:26 +0000
commit55573bc1f7f2fd3102ef9c9eb6254a59242c22b2 (patch)
tree5902f617ebbaa0b1e9bd491d2652d2d1fc2d755a /sys-apps/dbus/files
parentAdd patch to fix a possible overflow (reported by _FORTIFY_SOURCE=2); thanks ... (diff)
downloadgentoo-2-55573bc1f7f2fd3102ef9c9eb6254a59242c22b2.tar.gz
gentoo-2-55573bc1f7f2fd3102ef9c9eb6254a59242c22b2.tar.bz2
gentoo-2-55573bc1f7f2fd3102ef9c9eb6254a59242c22b2.zip
Version bump 1.4.0: fixed dohtml-related QA issue, sorted deps, rewritten --as-needed patch, dropped 1.3 patches applied upstream, added static-libs USE flag and .la files removal (this madness with installing useless .la files for shared libs has to stop).
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dbus/files')
-rw-r--r--sys-apps/dbus/files/dbus-1.4.0-asneeded.patch95
1 files changed, 95 insertions, 0 deletions
diff --git a/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch b/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch
new file mode 100644
index 000000000000..d26482b889d3
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch
@@ -0,0 +1,95 @@
+diff -ru ../dbus-1.4.0/dbus/Makefile.am ./dbus/Makefile.am
+--- ../dbus-1.4.0/dbus/Makefile.am 2010-08-31 23:44:19.000000000 +0200
++++ ./dbus/Makefile.am 2010-09-12 22:49:08.191226651 +0200
+@@ -277,7 +277,7 @@
+ dbus_test_SOURCES= \
+ dbus-test-main.c
+
+-dbus_test_LDADD=libdbus-internal.la $(DBUS_TEST_LIBS)
++dbus_test_LDADD=$(DBUS_TEST_LIBS) libdbus-internal.la
+ dbus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ ## mop up the gcov files
+diff -ru ../dbus-1.4.0/test/Makefile.am ./test/Makefile.am
+--- ../dbus-1.4.0/test/Makefile.am 2010-08-31 23:44:19.000000000 +0200
++++ ./test/Makefile.am 2010-09-12 22:51:44.021632252 +0200
+@@ -63,17 +63,17 @@
+
+ # When any programs are not linked to libdbus-internal, fix this.
+ AM_CPPFLAGS=-DDBUS_STATIC_BUILD
+-TEST_LIBS=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
++TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
+
+-test_service_LDADD=libdbus-testutils.la $(TEST_LIBS)
++test_service_LDADD=$(TEST_LIBS) libdbus-testutils.la
+ test_service_LDFLAGS=@R_DYNAMIC_LDFLAG@
+-test_names_LDADD=libdbus-testutils.la $(TEST_LIBS)
++test_names_LDADD=$(TEST_LIBS) libdbus-testutils.la
+ test_names_LDFLAGS=@R_DYNAMIC_LDFLAG@
+ ## break_loader_LDADD= $(TEST_LIBS)
+ ## break_loader_LDFLAGS=@R_DYNAMIC_LDFLAG@
+-test_shell_service_LDADD=libdbus-testutils.la $(TEST_LIBS)
++test_shell_service_LDADD=$(TEST_LIBS) libdbus-testutils.la
+ test_shell_service_LDFLAGS=@R_DYNAMIC_LDFLAG@
+-shell_test_LDADD=libdbus-testutils.la $(TEST_LIBS)
++shell_test_LDADD=$(TEST_LIBS) libdbus-testutils.la
+ shell_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+ spawn_test_LDADD=$(TEST_LIBS)
+ spawn_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+diff -ru ../dbus-1.4.0/test/name-test/Makefile.am ./test/name-test/Makefile.am
+--- ../dbus-1.4.0/test/name-test/Makefile.am 2010-08-31 23:44:19.000000000 +0200
++++ ./test/name-test/Makefile.am 2010-09-12 22:53:29.046971038 +0200
+@@ -22,46 +22,46 @@
+ test_pending_call_dispatch_SOURCES = \
+ test-pending-call-dispatch.c
+
+-test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
++test_pending_call_dispatch_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
+ test_pending_call_dispatch_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_pending_call_timeout_SOURCES = \
+ test-pending-call-timeout.c
+
+-test_pending_call_timeout_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
++test_pending_call_timeout_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
+ test_pending_call_timeout_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_threads_init_SOURCES = \
+ test-threads-init.c
+
+-test_threads_init_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
++test_threads_init_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
+ test_threads_init_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_ids_SOURCES = \
+ test-ids.c
+
+-test_ids_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
++test_ids_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
+ test_ids_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_shutdown_SOURCES = \
+ test-shutdown.c
+
+ test_shutdown_CFLAGS=
+-test_shutdown_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_shutdown_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
+ test_shutdown_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_privserver_SOURCES = \
+ test-privserver.c
+
+ test_privserver_CFLAGS=
+-test_privserver_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_privserver_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
+ test_privserver_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_privserver_client_SOURCES = \
+ test-privserver-client.c
+
+ test_privserver_client_CFLAGS=
+-test_privserver_client_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_privserver_client_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
+ test_privserver_client_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ endif