summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-02 09:15:35 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-02 09:15:35 +0000
commit9bf52b7b28c2fe041a503b532536e5f3ac8623a6 (patch)
treefb307bedaac41a24607b98ec2bac317874a36cdb /sci-libs
parentFixed automagic doxygen usage (diff)
downloadgentoo-2-9bf52b7b28c2fe041a503b532536e5f3ac8623a6.tar.gz
gentoo-2-9bf52b7b28c2fe041a503b532536e5f3ac8623a6.tar.bz2
gentoo-2-9bf52b7b28c2fe041a503b532536e5f3ac8623a6.zip
Fixed automagic doxygen usage
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mc/ChangeLog10
-rw-r--r--sci-libs/mc/files/1.4-doc.patch20
-rw-r--r--sci-libs/mc/mc-1.4.ebuild20
3 files changed, 44 insertions, 6 deletions
diff --git a/sci-libs/mc/ChangeLog b/sci-libs/mc/ChangeLog
index b3a112bd35f6..4e00d54a13b4 100644
--- a/sci-libs/mc/ChangeLog
+++ b/sci-libs/mc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/mc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/ChangeLog,v 1.1 2010/11/01 14:52:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/ChangeLog,v 1.2 2010/11/02 09:15:35 jlec Exp $
+
+ 02 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/1.4-doc.patch,
+ mc-1.4.ebuild:
+ Fixed automagic doxygen usage
+
+ 02 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/1.4-doc.patch,
+ mc-1.4.ebuild:
+ Fixed automagic doxygen usage
*mc-1.4 (01 Nov 2010)
diff --git a/sci-libs/mc/files/1.4-doc.patch b/sci-libs/mc/files/1.4-doc.patch
new file mode 100644
index 000000000000..f57777b8a419
--- /dev/null
+++ b/sci-libs/mc/files/1.4-doc.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
+index da96a19..afdf06d 100644
+--- a/doc/doxygen/Makefile.am
++++ b/doc/doxygen/Makefile.am
+@@ -29,13 +29,11 @@
+ ## Author: Michael Holst
+ ## ###########################################################################
+
+-docdir = @prefix@/doc/mc
+-
+ doc_DATA = mc_doc
+
+ mc_doc:
+ $(doxygen_path) $(top_srcdir)/doc/doxygen/mc.dox
+
+ install-docDATA:
+- mkdir -p $(docdir)
+- cp -r ../api $(docdir)/
++ mkdir -p $(DESTDIR)/@docdir@
++ cp -r ../api $(DESTDIR)/@docdir@/
diff --git a/sci-libs/mc/mc-1.4.ebuild b/sci-libs/mc/mc-1.4.ebuild
index 4c264229535b..e55edf5a0804 100644
--- a/sci-libs/mc/mc-1.4.ebuild
+++ b/sci-libs/mc/mc-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/mc-1.4.ebuild,v 1.1 2010/11/01 14:52:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/mc-1.4.ebuild,v 1.2 2010/11/02 09:15:35 jlec Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-2"
-IUSE="debug"
+IUSE="debug doc"
RDEPEND="
dev-libs/maloc
@@ -23,7 +23,11 @@ RDEPEND="
sci-libs/punc
sci-libs/superlu
sci-libs/umfpack"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )"
S="${WORKDIR}"/${PN}
@@ -31,7 +35,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PV}-superlu.patch \
"${FILESDIR}"/${PV}-overflow.patch \
- "${FILESDIR}"/${PV}-multilib.patch
+ "${FILESDIR}"/${PV}-multilib.patch \
+ "${FILESDIR}"/${PV}-doc.patch
sed \
-e 's:AMD_order:amd_order:g' \
-e 's:UMFPACK_numeric:umfpack_di_numeric:g' \
@@ -43,6 +48,9 @@ src_prepare() {
src_configure() {
local fetk_include
local fetk_lib
+ local myconf
+
+ use doc || myconf="${myconf} --with-doxygen= --with-dot="
fetk_include="${EPREFIX}"/usr/include
fetk_lib="${EPREFIX}"/usr/$(get_libdir)
@@ -60,9 +68,11 @@ src_configure() {
export FETK_PMG_LIBRARY="${fetk_lib}"
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_enable debug vdebug) \
--disable-triplet \
- --enable-shared
+ --enable-shared \
+ ${myconf}
}
src_install() {