summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-08-28 09:48:46 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-08-28 09:48:46 +0000
commitc5b6ccd2412ea972c97042828fc0cdc33a141a07 (patch)
treecd2d09c185ccd3c828c948fe705f909867274dc8 /sci-libs/blas-atlas
parentExplicitly disable papi backend or it will automagically use it. (diff)
downloadgentoo-2-c5b6ccd2412ea972c97042828fc0cdc33a141a07.tar.gz
gentoo-2-c5b6ccd2412ea972c97042828fc0cdc33a141a07.tar.bz2
gentoo-2-c5b6ccd2412ea972c97042828fc0cdc33a141a07.zip
Add fix to compile on alpha, alpha stable wrt #200336
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/blas-atlas')
-rw-r--r--sci-libs/blas-atlas/ChangeLog6
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild7
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild6
3 files changed, 15 insertions, 4 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 2e903c097e5b..10ca17c09219 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.85 2008/08/16 10:50:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.86 2008/08/28 09:48:46 armin76 Exp $
+
+ 28 Aug 2008; Raúl Porcel <armin76@gentoo.org> blas-atlas-3.8.0.ebuild,
+ blas-atlas-3.9.3.ebuild:
+ Add fix to compile on alpha, alpha stable wrt #200336
*blas-atlas-3.9.3 (15 Aug 2008)
diff --git a/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild b/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild
index 6e364f98ceef..cc35bc5b4db8 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild,v 1.10 2008/04/21 15:59:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild,v 1.11 2008/08/28 09:48:46 armin76 Exp $
inherit eutils toolchain-funcs fortran multilib
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
IUSE="doc"
RDEPEND="app-admin/eselect-blas
@@ -80,6 +80,9 @@ src_unpack() {
archselect="-b 32"
fi
+ # Remove -m64 on alpha, since the compiler doesn't support it
+ use alpha && sed -i -e 's/-m64//g' "${S}"/CONFIG/src/probe_comp.c
+
../configure \
--cc="$(tc-getCC)" \
--cflags="${CFLAGS}" \
diff --git a/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild b/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild
index 747f7e261c2e..93439eb382da 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild,v 1.1 2008/08/16 10:50:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.9.3.ebuild,v 1.2 2008/08/28 09:48:46 armin76 Exp $
inherit eutils toolchain-funcs fortran multilib
@@ -75,6 +75,10 @@ src_unpack() {
archselect="-b 32"
fi
+ # Remove -m64 on alpha, since the compiler doesn't support it
+ use alpha && sed -i -e 's/-m64//g' "${S}"/CONFIG/src/probe_comp.c
+
+
# unfortunately, atlas-3.9.0 chokes when passed
# x86_64-pc-linux-gnu-gcc and friends instead of
# plain gcc. Hence, we'll have to workaround this