summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-06-21 20:14:18 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-06-21 20:14:18 +0000
commit124d6ce8b0267b7abdf1688089f9a07f295c693a (patch)
tree8a15f625bf9e6fd12e0fb51667a648bf84326556 /net-misc/dhcpcd
parentFix test dependencies. (diff)
downloadgentoo-2-124d6ce8b0267b7abdf1688089f9a07f295c693a.tar.gz
gentoo-2-124d6ce8b0267b7abdf1688089f9a07f295c693a.tar.bz2
gentoo-2-124d6ce8b0267b7abdf1688089f9a07f295c693a.zip
revert patch from bug 350511, add systemd support for bug 372437 and
migrate to eapi 4. Thanks to mgorny@gentoo.org for systemd support. (Portage version: 2.2.0_alpha41/cvs/Linux i686)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog9
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.2.12-r1.ebuild94
-rw-r--r--net-misc/dhcpcd/files/dhcpcd.service8
3 files changed, 110 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index ade909ae0356..fe7d9029d9ca 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.320 2011/04/15 21:39:14 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.321 2011/06/21 20:14:18 williamh Exp $
+
+*dhcpcd-5.2.12-r1 (21 Jun 2011)
+
+ 21 Jun 2011; William Hubbs <williamh@gentoo.org> +dhcpcd-5.2.12-r1.ebuild,
+ +files/dhcpcd.service:
+ revert patch from bug 350511, add systemd support for bug 372437 and
+ migrate to eapi 4. Thanks to mgorny@gentoo.org for systemd support.
15 Apr 2011; Ulrich Mueller <ulm@gentoo.org> dhcpcd-5.2.12.ebuild:
Don't PROVIDE virtual/dhcpc, bug 358827.
diff --git a/net-misc/dhcpcd/dhcpcd-5.2.12-r1.ebuild b/net-misc/dhcpcd/dhcpcd-5.2.12-r1.ebuild
new file mode 100644
index 000000000000..d230aba1ecbb
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-5.2.12-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.2.12-r1.ebuild,v 1.1 2011/06/21 20:14:18 williamh Exp $
+
+EAPI=4
+
+inherit eutils systemd
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+SLOT="0"
+IUSE="+zeroconf elibc_glibc"
+
+DEPEND=""
+RDEPEND="!<sys-apps/openrc-0.6.0"
+
+src_prepare() {
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+}
+
+src_configure() {
+ local hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ econf \
+ --prefix= \
+ --libexecdir=/lib/dhcpcd \
+ --dbdir=/var/lib/dhcpcd \
+ --localstatedir=/var \
+ ${hooks}
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+ newinitd "${FILESDIR}"/${PN}.initd-1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ elog
+ elog "Users upgrading from 4.0 series should pay attention to removal"
+ elog "of compat useflag. This changes behavior of dhcp in wide manner:"
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+ elog
+ elog "Also, users upgrading from 4.0 series should be aware that"
+ elog "the -N, -R and -Y command line options no longer exist."
+ elog "These are controled now by nohook options in dhcpcd.conf."
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd.service b/net-misc/dhcpcd/files/dhcpcd.service
new file mode 100644
index 000000000000..46a6567e05e3
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Lightweight DHCP client daemon
+
+[Service]
+ExecStart=/sbin/dhcpcd -q --nobackground
+
+[Install]
+WantedBy=network.target