summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-08-01 23:40:13 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-08-01 23:40:13 +0000
commitc25746574eccb9240e3efc3858b2baf2e0e04838 (patch)
tree0581fc6878305e65e75fcbc17f5d39f358655eef /net-libs/libosmocore
parentStable for HPPA (bug #393811). (diff)
downloadgentoo-2-c25746574eccb9240e3efc3858b2baf2e0e04838.tar.gz
gentoo-2-c25746574eccb9240e3efc3858b2baf2e0e04838.tar.bz2
gentoo-2-c25746574eccb9240e3efc3858b2baf2e0e04838.zip
Build and pkgconfig files fixes. Drop old.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libosmocore')
-rw-r--r--net-libs/libosmocore/ChangeLog9
-rw-r--r--net-libs/libosmocore/files/libosmocore-0.5.2-gcc-4.6.patch22
-rw-r--r--net-libs/libosmocore/libosmocore-0.4.2.ebuild42
-rw-r--r--net-libs/libosmocore/libosmocore-0.5.2-r1.ebuild (renamed from net-libs/libosmocore/libosmocore-0.5.2.ebuild)8
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild4
5 files changed, 39 insertions, 46 deletions
diff --git a/net-libs/libosmocore/ChangeLog b/net-libs/libosmocore/ChangeLog
index f6c8f5fee66f..e13856c08ae8 100644
--- a/net-libs/libosmocore/ChangeLog
+++ b/net-libs/libosmocore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libosmocore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.3 2012/07/05 23:37:08 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.4 2012/08/01 23:40:13 chithanh Exp $
+
+*libosmocore-0.5.2-r1 (01 Aug 2012)
+
+ 01 Aug 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/libosmocore-0.5.2-gcc-4.6.patch, +libosmocore-0.5.2-r1.ebuild,
+ -libosmocore-0.4.2.ebuild, -libosmocore-0.5.2.ebuild, libosmocore-9999.ebuild:
+ Build and pkgconfig files fixes. Drop old.
*libosmocore-0.5.2 (05 Jul 2012)
diff --git a/net-libs/libosmocore/files/libosmocore-0.5.2-gcc-4.6.patch b/net-libs/libosmocore/files/libosmocore-0.5.2-gcc-4.6.patch
new file mode 100644
index 000000000000..b8bb4329f8ed
--- /dev/null
+++ b/net-libs/libosmocore/files/libosmocore-0.5.2-gcc-4.6.patch
@@ -0,0 +1,22 @@
+diff -ur a/tests/timer/timer_test.c b/tests/timer/timer_test.c
+--- a/tests/timer/timer_test.c 2012-06-30 22:01:44.000000000 +0200
++++ b/tests/timer/timer_test.c 2012-08-02 01:16:45.639858402 +0200
+@@ -26,6 +26,7 @@
+ #include <stdlib.h>
+ #include <signal.h>
+ #include <getopt.h>
++#include <unistd.h>
+
+ #include <osmocom/core/talloc.h>
+ #include <osmocom/core/timer.h>
+diff -ur a/utils/osmo-auc-gen.c b/utils/osmo-auc-gen.c
+--- a/utils/osmo-auc-gen.c 2012-06-30 22:01:44.000000000 +0200
++++ b/utils/osmo-auc-gen.c 2012-08-02 01:17:08.985860119 +0200
+@@ -26,6 +26,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <getopt.h>
++#include <time.h>
+
+ #include <osmocom/crypt/auth.h>
+ #include <osmocom/core/utils.h>
diff --git a/net-libs/libosmocore/libosmocore-0.4.2.ebuild b/net-libs/libosmocore/libosmocore-0.4.2.ebuild
deleted file mode 100644
index 478ba0e7f75c..000000000000
--- a/net-libs/libosmocore/libosmocore-0.4.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.4.2.ebuild,v 1.1 2012/06/15 13:51:23 chithanh Exp $
-
-EAPI="4"
-inherit autotools
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-2
- SRC_URI=""
- EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
-HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
-
-LICENSE="GPL-2 LGPL-3"
-SLOT="0"
-IUSE="embedded"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-doc/doxygen"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable embedded)
-}
-
-src_install() {
- default
- # install to correct documentation directory
- mv "${ED}"/usr/share/doc/${PN}/${PN}-* "${ED}"/usr/share/doc/${PF} || die
- rmdir "${ED}"/usr/share/doc/${PN}/ || die
-}
diff --git a/net-libs/libosmocore/libosmocore-0.5.2.ebuild b/net-libs/libosmocore/libosmocore-0.5.2-r1.ebuild
index 02f8ccaf01fc..75499f75a711 100644
--- a/net-libs/libosmocore/libosmocore-0.5.2.ebuild
+++ b/net-libs/libosmocore/libosmocore-0.5.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.5.2.ebuild,v 1.1 2012/07/05 23:37:08 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.5.2-r1.ebuild,v 1.1 2012/08/01 23:40:13 chithanh Exp $
EAPI="4"
-inherit autotools
+inherit autotools eutils
if [[ ${PV} == 9999* ]]; then
inherit git-2
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}
app-doc/doxygen"
src_prepare() {
+ # fix building against gcc-4.6
+ epatch "${FILESDIR}"/${P}-gcc-4.6.patch
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
eautoreconf
}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
index 54da8cf478b1..e47e8b7dbf1d 100644
--- a/net-libs/libosmocore/libosmocore-9999.ebuild
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.2 2012/07/05 23:37:08 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.3 2012/08/01 23:40:13 chithanh Exp $
EAPI="4"
inherit autotools
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
app-doc/doxygen"
src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
eautoreconf
}