summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-23 10:23:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-23 10:23:46 +0000
commitfc62be304fc914d961ffea876a538e3665657b2a (patch)
tree339521053ec328a2c586cc5f9f77682f632737d6 /net-libs/libgssglue/libgssglue-0.4.ebuild
parentInitial commit. Ebuild based on the one by Oliver Jaksch in bug #341957, with... (diff)
downloadgentoo-2-fc62be304fc914d961ffea876a538e3665657b2a.tar.gz
gentoo-2-fc62be304fc914d961ffea876a538e3665657b2a.tar.bz2
gentoo-2-fc62be304fc914d961ffea876a538e3665657b2a.zip
Version bump wrt security #385321
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libgssglue/libgssglue-0.4.ebuild')
-rw-r--r--net-libs/libgssglue/libgssglue-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libgssglue/libgssglue-0.4.ebuild b/net-libs/libgssglue/libgssglue-0.4.ebuild
new file mode 100644
index 000000000000..323659e27971
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgssglue/libgssglue-0.4.ebuild,v 1.1 2012/08/23 10:23:46 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-crypt/libgssapi"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.3-protos.patch \
+ "${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
+}
+
+src_configure() {
+ # No need to install static libraries, as it uses libdl
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ insinto /etc
+ doins doc/gssapi_mech.conf
+}