summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-23 00:25:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-23 00:25:43 +0000
commita57639486d25b0005c1584310ed8e73700287e6c (patch)
treea37ec8748f194c0735ee39ccac6feb8b260e0475 /net-libs/http-parser
parentAdd ruby:2.2 and drop ruby:1.9 support. (diff)
downloadgentoo-2-a57639486d25b0005c1584310ed8e73700287e6c.tar.gz
gentoo-2-a57639486d25b0005c1584310ed8e73700287e6c.tar.bz2
gentoo-2-a57639486d25b0005c1584310ed8e73700287e6c.zip
Proxy commit for Johan Bergström. Version bump. Add him as proxied maintainer.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/ChangeLog10
-rw-r--r--net-libs/http-parser/http-parser-2.4.1.ebuild43
-rw-r--r--net-libs/http-parser/metadata.xml5
3 files changed, 55 insertions, 3 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
index 0ab56f157a3f..617073624f31 100644
--- a/net-libs/http-parser/ChangeLog
+++ b/net-libs/http-parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/http-parser
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.11 2014/12/31 15:55:41 kensington Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.12 2015/01/23 00:25:43 mrueg Exp $
+
+*http-parser-2.4.1 (23 Jan 2015)
+
+ 23 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +http-parser-2.4.1.ebuild,
+ metadata.xml:
+ Proxy commit for Johan Bergström. Version bump. Add him as proxied maintainer.
31 Dec 2014; Michael Palimaka <kensington@gentoo.org> -http-parser-2.1.ebuild:
Remove old.
diff --git a/net-libs/http-parser/http-parser-2.4.1.ebuild b/net-libs/http-parser/http-parser-2.4.1.ebuild
new file mode 100644
index 000000000000..4ac443f31b15
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.4.1.ebuild,v 1.1 2015/01/23 00:25:43 mrueg Exp $
+
+EAPI=5
+
+SONAME="libhttp_parser.so.${PV}"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="http request/response parser for c"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+
+ sed -i -e 's: -Werror::' \
+ -e 's:-O3 ::' \
+ Makefile || die
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake library
+ use static-libs && emake package
+}
+
+multilib_src_install() {
+ doheader http_parser.h
+ dolib.so ${SONAME}
+ dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+ use static-libs && dolib.a libhttp_parser.a
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+}
diff --git a/net-libs/http-parser/metadata.xml b/net-libs/http-parser/metadata.xml
index 91f4e72fb544..62e5578cfa83 100644
--- a/net-libs/http-parser/metadata.xml
+++ b/net-libs/http-parser/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Proxied Maintainer</description>
</maintainer>
</pkgmetadata>