summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-21 09:54:24 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-21 09:54:24 +0000
commit5b54ce9c2974c99ecffae6b992e61958d35870df (patch)
tree3933939cf70baae8d1e614c90d2eefe0342203d3 /net-libs/http-parser
parentunmask latest sssd (diff)
downloadgentoo-2-5b54ce9c2974c99ecffae6b992e61958d35870df.tar.gz
gentoo-2-5b54ce9c2974c99ecffae6b992e61958d35870df.tar.bz2
gentoo-2-5b54ce9c2974c99ecffae6b992e61958d35870df.zip
version bump wrt #514154
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/ChangeLog10
-rw-r--r--net-libs/http-parser/files/http-parser-2.3-flags.patch32
-rw-r--r--net-libs/http-parser/http-parser-2.3.ebuild39
3 files changed, 79 insertions, 2 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
index ab82fb3aab38..a7750b00e0b8 100644
--- a/net-libs/http-parser/ChangeLog
+++ b/net-libs/http-parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/http-parser
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.3 2013/09/05 19:23:27 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.4 2014/06/21 09:54:24 hasufell Exp $
+
+*http-parser-2.3 (21 Jun 2014)
+
+ 21 Jun 2014; Julian Ospald <hasufell@gentoo.org> +http-parser-2.3.ebuild,
+ +files/http-parser-2.3-flags.patch:
+ version bump wrt #514154
05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> http-parser-2.1.ebuild:
Stable for x86, wrt bug #482608
diff --git a/net-libs/http-parser/files/http-parser-2.3-flags.patch b/net-libs/http-parser/files/http-parser-2.3-flags.patch
new file mode 100644
index 000000000000..3dc9b3305ad7
--- /dev/null
+++ b/net-libs/http-parser/files/http-parser-2.3-flags.patch
@@ -0,0 +1,32 @@
+commit 3752e633e23284133decc8ca8481e4416a317fbc
+Author: hasufell <hasufell@gentoo.org>
+Date: Sun Jun 30 12:27:04 2013 +0200
+
+ respect system flags
+
+diff --git a/Makefile b/Makefile
+index 64e5c2f..2e20723 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,9 +7,9 @@ CPPFLAGS_DEBUG += $(CPPFLAGS_DEBUG_EXTRA)
+ CPPFLAGS_FAST = $(CPPFLAGS) -DHTTP_PARSER_STRICT=0
+ CPPFLAGS_FAST += $(CPPFLAGS_FAST_EXTRA)
+
+-CFLAGS += -Wall -Wextra -Werror
+-CFLAGS_DEBUG = $(CFLAGS) -O0 -g $(CFLAGS_DEBUG_EXTRA)
+-CFLAGS_FAST = $(CFLAGS) -O3 $(CFLAGS_FAST_EXTRA)
++CFLAGS += -Wall -Wextra
++CFLAGS_DEBUG = $(CFLAGS) $(CFLAGS_DEBUG_EXTRA)
++CFLAGS_FAST = $(CFLAGS) $(CFLAGS_FAST_EXTRA)
+ CFLAGS_LIB = $(CFLAGS_FAST) -fPIC
+
+ test: test_g test_fast
+@@ -44,7 +44,7 @@ libhttp_parser.o: http_parser.c http_parser.h Makefile
+ $(CC) $(CPPFLAGS_FAST) $(CFLAGS_LIB) -c http_parser.c -o libhttp_parser.o
+
+ library: libhttp_parser.o
+- $(CC) $(LDFLAGS_LIB) -o $(SONAME) $<
++ $(CC) $(CFLAGS) $(LDFLAGS_LIB) -o $(SONAME) $<
+
+ package: http_parser.o
+ $(AR) rcs libhttp_parser.a http_parser.o
diff --git a/net-libs/http-parser/http-parser-2.3.ebuild b/net-libs/http-parser/http-parser-2.3.ebuild
new file mode 100644
index 000000000000..0dbb1f62e0ac
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.3.ebuild,v 1.1 2014/06/21 09:54:24 hasufell Exp $
+
+EAPI=5
+
+SONAMEVER="2.3"
+SONAME="libhttp_parser.so.${SONAMEVER}"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="A parser for HTTP messages written in C. It parses both requests and responses"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${SONAMEVER}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}"/${P}-flags.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake library
+}
+
+multilib_src_install() {
+ doheader http_parser.h
+ dolib.so ${SONAME}
+ dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+}