summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-01-14 08:29:30 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-01-14 08:29:30 +0000
commit41c01909a5975f99fae4a5f29b296efeb59e9f39 (patch)
tree5fbf43ad28372bae64909548b07a635133f0261b /net-im
parentAdded ~x86 keyword (diff)
downloadgentoo-2-41c01909a5975f99fae4a5f29b296efeb59e9f39.tar.gz
gentoo-2-41c01909a5975f99fae4a5f29b296efeb59e9f39.tar.bz2
gentoo-2-41c01909a5975f99fae4a5f29b296efeb59e9f39.zip
Long overdue version bump (bug #339673)
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog10
-rw-r--r--net-im/licq/licq-1.7.0.ebuild81
-rw-r--r--net-im/licq/metadata.xml4
3 files changed, 93 insertions, 2 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 450b18c99d3a..8c6d9f565e29 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/licq
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.118 2010/05/17 19:54:11 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.119 2013/01/14 08:29:30 polynomial-c Exp $
+
+*licq-1.7.0 (14 Jan 2013)
+
+ 14 Jan 2013; Lars Wendler <polynomial-c@gentoo.org> +licq-1.7.0.ebuild,
+ metadata.xml:
+ non-maintainer commit: Long overdue version bump (bug #339673).
*licq-1.3.9 (17 May 2010)
diff --git a/net-im/licq/licq-1.7.0.ebuild b/net-im/licq/licq-1.7.0.ebuild
new file mode 100644
index 000000000000..6a92910f5fc1
--- /dev/null
+++ b/net-im/licq/licq-1.7.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.7.0.ebuild,v 1.1 2013/01/14 08:29:30 polynomial-c Exp $
+
+EAPI="5"
+
+inherit cmake-utils eutils flag-o-matic
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc linguas_he nls socks5 ssl xosd aosd jabber qt4 msn ncurses"
+
+RDEPEND=">=app-crypt/gpgme-1
+ jabber? ( net-libs/gloox )
+ qt4? ( x11-libs/qt-gui:4 )
+ ssl? ( >=dev-libs/openssl-0.9.5a )
+ ncurses? (
+ sys-libs/ncurses
+ dev-libs/cdk
+ )
+ xosd? ( x11-libs/xosd )
+ aosd? ( x11-libs/libaosd )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ dev-libs/boost"
+
+src_prepare() {
+ #epatch "${FILESDIR}"/${PN}-1.5.1-find-libcdk.patch
+
+ local licq_plugins="auto-reply rms"
+ use ncurses && licq_plugins+=" console"
+ use msn && licq_plugins+=" msn"
+ use xosd && licq_plugins+=" osd"
+ use aosd && licq_plugins+=" aosd"
+ use jabber && licq_plugins+=" jabber"
+ use qt4 && licq_plugins+=" qt4-gui"
+
+ local plugins="" x
+ for x in ${licq_plugins}; do
+ plugins+=" ${x}\/CMakeLists.txt"
+ done
+
+ sed -i -e "s/file(GLOB cmake_plugins.*$/set(cmake_plugins ${plugins})/" plugins/CMakeLists.txt
+}
+
+pkg_setup() {
+ # crutch
+ append-flags -pthread
+}
+
+src_configure() {
+ local myopts="-DCMAKE_BUILD_TYPE=$(use debug && echo 'Debug' || echo 'Release')"
+ mycmakeargs="$myopts
+ $(cmake-utils_use linguas_he USE_HEBREW)
+ $(cmake-utils_use socks5 USE_SOCKS5)
+ $(cmake-utils_use ssl USE_OPENSSL)
+ $(cmake-utils_use nls ENABLE_NLS)
+ -DUSE_FIFO=ON
+ -DBUILD_PLUGINS=ON"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README
+
+ docinto doc
+ dodoc doc/*
+
+ use ssl && dodoc README.OPENSSL
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe upgrade/*.pl || die
+}
diff --git a/net-im/licq/metadata.xml b/net-im/licq/metadata.xml
index 2d3b94c99ae6..8c13b30c5f6c 100644
--- a/net-im/licq/metadata.xml
+++ b/net-im/licq/metadata.xml
@@ -3,4 +3,8 @@
<pkgmetadata>
<herd>net-im</herd>
<longdescription>Licq is an ICQ clone with an extensive plugin system.</longdescription>
+
+<use>
+ <flag name="aosd">Build the advanced on screen display plugin.</flag>
+</use>
</pkgmetadata>