summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-09-27 14:14:59 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-09-27 14:14:59 +0000
commitd97dfe00baedabd0a87ee0915602d8cd0a7588f0 (patch)
treebd2be31e2dc0083119159d14600de87a8d755785 /net-dialup
parentmake module-init-tools the default (sorry lv) (diff)
downloadgentoo-2-d97dfe00baedabd0a87ee0915602d8cd0a7588f0.tar.gz
gentoo-2-d97dfe00baedabd0a87ee0915602d8cd0a7588f0.tar.bz2
gentoo-2-d97dfe00baedabd0a87ee0915602d8cd0a7588f0.zip
Initial ebuild thanks to Alin Nastac <mrness@gentoo.ro> in bug #3578. No joke about the bug number. Who says gentoo ignores old bugs :-)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/bewan-adsl/ChangeLog10
-rw-r--r--net-dialup/bewan-adsl/Manifest2
-rw-r--r--net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild89
-rw-r--r--net-dialup/bewan-adsl/files/digest-bewan-adsl-0.8.71
-rw-r--r--net-dialup/bewan-adsl/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/net-dialup/bewan-adsl/ChangeLog b/net-dialup/bewan-adsl/ChangeLog
new file mode 100644
index 000000000000..f5f789143689
--- /dev/null
+++ b/net-dialup/bewan-adsl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/bewan-adsl
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.1 2004/09/27 14:14:59 dragonheart Exp $
+
+*bewan-adsl-0.8.7 (27 Sep 2004)
+
+ 27 Sep 2004; Daniel Black <dragonheart@gentoo.org> +bewan-adsl-0.8.7.ebuild
+ +metadata.xml:
+ Initial ebuild thanks to Alin Nastac <mrness@gentoo.ro> in bug #3578
+
diff --git a/net-dialup/bewan-adsl/Manifest b/net-dialup/bewan-adsl/Manifest
new file mode 100644
index 000000000000..ed43861d8e06
--- /dev/null
+++ b/net-dialup/bewan-adsl/Manifest
@@ -0,0 +1,2 @@
+MD5 0804198cf11436a0e78b79d3f90725be bewan-adsl-0.8.7.ebuild 2133
+MD5 96c16fb5ea4312bc3e4b2300e0a7ce69 files/digest-bewan-adsl-0.8.7 59
diff --git a/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild b/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild
new file mode 100644
index 000000000000..38ea4e89d1a8
--- /dev/null
+++ b/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild,v 1.1 2004/09/27 14:14:59 dragonheart Exp $
+
+inherit eutils kmod
+
+DESCRIPTION="Bewan ADSL PCI&USB st driver"
+SRC_URI="http://www.bewan.com/bewan/drivers/bast-${PV}.tgz"
+HOMEPAGE="http://www.bewan.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="usb doc"
+
+S="${WORKDIR}/unicorn"
+
+src_compile() {
+ get_kernel_info || die
+ #kmod_make_linux_writable || die #without this we cannot compile this driver for 2.6 kernels
+
+ einfo "Build common library"
+ cd ${S}/libm
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+
+ (
+ unset ARCH #unset ARCH because interfere with 2.6 kernel makefiles
+
+ einfo "Build PCI driver"
+ cd ${S}/unicorn_pci
+ emake || die
+ [ -f unicorn_pci_atm.${KV_OBJ} ] && [ -f unicorn_pci_eth.${KV_OBJ} ] \
+ || die "Failed to build PCI driver"
+
+ if use usb; then
+ einfo "Build USB driver"
+ cd ${S}/unicorn_usb
+ emake || die
+ [ -f unicorn_usb_atm.${KV_OBJ} ] && [ -f unicorn_usb_eth.${KV_OBJ} ] \
+ || die "Failed to build USB driver"
+ fi
+ )
+
+ #Build tools
+ cd ${S}/tools
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ cd ${S}
+ insinto "/lib/modules/${KV}/kernel/drivers/atm"
+ doins unicorn_pci/unicorn_pci_atm.${KV_OBJ} && \
+ doins unicorn_pci/unicorn_pci_eth.${KV_OBJ} || \
+ die "PCI driver not found! Install aborted."
+ if use usb; then
+ doins unicorn_usb/unicorn_usb_atm.${KV_OBJ} && \
+ doins unicorn_usb/unicorn_usb_eth.${KV_OBJ} || \
+ die "USB driver not found! Install aborted."
+ fi
+
+ #Install tools
+ dodir /usr/bin
+ cd ${S}/tools && einstall DESTDIR=${D} prefix=/usr || \
+ die "Cannot install tools"
+
+ if use doc; then
+ #Install documantation
+ cd ${S}
+ dodoc README
+ docinto Documentation
+ dodoc Documentation/*
+ docinto RFCs
+ dodoc RFCs/*
+ docinto scripts
+ dodoc scripts/*
+ fi
+}
+
+pkg_postinst() {
+ einfo "Regenerate modules dependencies for kernel ${KV}"
+ depmod -ae ${KV}
+ eend $?
+ einfo ""
+ einfo "To load the driver do 'insmod unicorn_atm' and 'insmod unicorn_pci' "
+ einfo "and then do what you want with it (configure your pppd)"
+ einfo "OR"
+ einfo "it's time to look at the README file, the scripts directory gives you"
+ einfo "two comprehensive ways to load the driver, configure pppd and launch it."
+}
+
diff --git a/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.8.7 b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.8.7
new file mode 100644
index 000000000000..c1b21fd762ee
--- /dev/null
+++ b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.8.7
@@ -0,0 +1 @@
+MD5 44bf4c9d159135e27a723d71214c6ab9 bast-0.8.7.tgz 918004
diff --git a/net-dialup/bewan-adsl/metadata.xml b/net-dialup/bewan-adsl/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/bewan-adsl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>