summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-06-04 18:37:45 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-06-04 18:37:45 +0000
commitacb3bd9ff23ba1599eff5eb21eba2d516235b90c (patch)
tree200baec82d8c12778f28beefbc4c4dd09bc7c666 /net-analyzer
parentAdding new yaboot-static-1.3.14_pre1 (diff)
downloadgentoo-2-acb3bd9ff23ba1599eff5eb21eba2d516235b90c.tar.gz
gentoo-2-acb3bd9ff23ba1599eff5eb21eba2d516235b90c.tar.bz2
gentoo-2-acb3bd9ff23ba1599eff5eb21eba2d516235b90c.zip
Version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog8
-rw-r--r--net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.4.93
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.9.ebuild124
3 files changed, 134 insertions, 1 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 490482b7c4e1..a2d89c8fee67 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.61 2007/05/11 17:44:20 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.62 2007/06/04 18:37:45 dertobi123 Exp $
+
+*nagios-plugins-1.4.9 (04 Jun 2007)
+
+ 04 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-plugins-1.4.9.ebuild:
+ Version bump
*nagios-plugins-1.4.8-r1 (11 May 2007)
diff --git a/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.4.9 b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.4.9
new file mode 100644
index 000000000000..4e147c6806a0
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.4.9
@@ -0,0 +1,3 @@
+MD5 6e617e95cadeedd92870cdbd2f13726c nagios-plugins-1.4.9.tar.gz 1370263
+RMD160 fdbe8cf1fc2ec6886b03a41542e1eda26d220186 nagios-plugins-1.4.9.tar.gz 1370263
+SHA256 93cf5dadfb092d7c4d600a713bbef75d37141edb4d18ac3bc3c0d1c09f4b7fe2 nagios-plugins-1.4.9.tar.gz 1370263
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.9.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.9.ebuild
new file mode 100644
index 000000000000..55c8eb319c0d
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.9.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.9.ebuild,v 1.1 2007/06/04 18:37:45 dertobi123 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagiosplug/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl samba mysql postgres ldap snmp nagios-dns nagios-ntp nagios-ping
+nagios-ssh nagios-game ups ipv6 radius"
+
+DEPEND="ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( virtual/mysql )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ radius? ( >=net-dialup/radiusclient-0.3.2 )"
+
+RESTRICT="test"
+
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.6.1-r7
+ samba? ( >=net-fs/samba-2.2.5-r1 )
+ snmp? ( >=dev-perl/Net-SNMP-4.0.1-r1
+ >=net-analyzer/net-snmp-5.0.6
+ )
+ mysql? ( dev-perl/DBI
+ dev-perl/DBD-mysql )
+ nagios-dns? ( >=net-dns/bind-tools-9.2.2_rc1 )
+ nagios-ntp? ( >=net-misc/ntp-4.1.1a )
+ nagios-ping? ( >=net-analyzer/fping-2.4_beta2-r1 )
+ nagios-ssh? ( >=net-misc/openssh-3.5_p1 )
+ ups? ( >=sys-power/nut-1.4 )
+ !sparc? ( nagios-game? ( >=games-util/qstat-2.6 ) )"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use radius; then
+ EPATCH_OPTS="-p0 -d ${S}" epatch \
+ ${FILESDIR}/nagios-plugins-1.4-noradius.patch
+ fi
+
+ epatch ${FILESDIR}/${PN}-1.4-contrib.patch
+
+ AT_M4DIR="m4 gl/m4" eautoreconf
+}
+
+src_compile() {
+
+ local conf
+ if use ssl; then
+ conf="${conf} --with-openssl=/usr"
+ else
+ conf="${conf} --without-openssl"
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres) \
+ $(use_with ipv6) \
+ ${conf} \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "econf failed"
+
+ # fix problem with additional -
+ sed -i -e 's:/bin/ps -axwo:/bin/ps axwo:g' config.h || die "sed failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ mv ${S}/contrib/check_compaq_insight.pl ${S}/contrib/check_compaq_insight.pl.msg
+ chmod +x ${S}/contrib/*.pl
+
+ sed -i -e '1s;#!.*;#!/usr/bin/perl -w;' ${S}/contrib/*.pl || die "sed failed"
+ sed -i -e '30s/use lib utils.pm;/use utils;/' \
+ ${S}/plugins-scripts/check_file_age.pl || die "sed failed"
+
+ dodoc ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CHANGES CODING COPYING \
+ Changelog FAQ INSTALL LEGAL NEWS README REQUIREMENTS SUPPORT
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use mysql || use postgres; then
+ dodir /usr/nagios/libexec
+ exeinto /usr/nagios/libexec
+ doexe ${S}/contrib/check_nagios_db.pl
+ fi
+
+ dodir /usr/nagios/libexec/
+ mv ${S}/contrib ${D}/usr/nagios/libexec/contrib
+
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}usr/nagios/libexec"
+
+ chmod -R o-rwx ${D}/usr/nagios/libexec || "Failed Chmod of ${D}usr/nagios/libexec"
+
+ chown root:nagios ${D}/usr/nagios/libexec/check_icmp || "Failed Chown of ${D}/usr/nagios/libexec/check_icmp"
+ chmod 04710 ${D}/usr/nagios/libexec/check_icmp || "Failed Chmod of ${D}usr/nagios/libexec/check_icmp"
+}
+
+pkg_postinst() {
+ einfo "This ebuild has a number of USE flags which determines what nagios is able to monitor."
+ einfo "Depending on what you want to monitor with nagios, some or all of these USE"
+ einfo "flags need to be set for nagios to function correctly."
+ echo
+ einfo "contrib plugins are installed into /usr/nagios/libexec/contrib"
+}
+