summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-02 04:42:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-02 04:42:58 +0000
commitc68932259b2e6be1d922183cabd6d49e8b44a3f4 (patch)
treee3b90b3ccda207ad170c808529e906559b8949f5 /net-analyzer/metasploit
parentMask libnl as per bug #414317. (diff)
downloadgentoo-2-c68932259b2e6be1d922183cabd6d49e8b44a3f4.tar.gz
gentoo-2-c68932259b2e6be1d922183cabd6d49e8b44a3f4.tar.bz2
gentoo-2-c68932259b2e6be1d922183cabd6d49e8b44a3f4.zip
Bump, drop ppc keyword until msgpack is keyworded
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/metasploit')
-rw-r--r--net-analyzer/metasploit/ChangeLog8
-rw-r--r--net-analyzer/metasploit/files/msfrpcd-4.3-conf25
-rw-r--r--net-analyzer/metasploit/files/msfrpcd-4.3-initd22
-rw-r--r--net-analyzer/metasploit/metasploit-4.3.0.ebuild92
4 files changed, 146 insertions, 1 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index e0953ebdd757..b44d87933b89 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/metasploit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.61 2012/04/21 16:54:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.62 2012/05/02 04:42:58 patrick Exp $
+
+*metasploit-4.3.0 (02 May 2012)
+
+ 02 May 2012; Patrick Lauer <patrick@gentoo.org> +files/msfrpcd-4.3-conf,
+ +files/msfrpcd-4.3-initd, +metasploit-4.3.0.ebuild:
+ Bump, drop ppc keyword until msgpack is keyworded
21 Apr 2012; Raúl Porcel <armin76@gentoo.org> metasploit-2.7.ebuild,
metasploit-4.0.0-r1.ebuild, metasploit-4.2.0.ebuild:
diff --git a/net-analyzer/metasploit/files/msfrpcd-4.3-conf b/net-analyzer/metasploit/files/msfrpcd-4.3-conf
new file mode 100644
index 000000000000..dc56a9d966a6
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfrpcd-4.3-conf
@@ -0,0 +1,25 @@
+# Config file for /etc/init.d/msfrpcd
+
+# msfrpcd -h for more info
+
+# Bind to the following IP instead of 0.0.0.0
+MSF_OPTS="-a 127.0.0.1"
+
+# Bind to the following TCP port instead of default 55553
+#MSF_OPTS="${MSF_OPTS} -p 55553"
+
+# Specify the username to access msfrpcd
+MSF_OPTS="${MSF_OPTS} -U msf"
+
+# Specify the password to access msfrpcd
+MSF_OPTS="${MSF_OPTS} -P secret"
+
+# Server type, [Basic|Web]
+#MSF_OPTS="${MSF_OPTS} -t Basic"
+
+# URI for Web server
+#MSF_OPTS="${MSF_OPTS} -u "
+
+# Disable SSL on the XMLRPC socket
+# JAVA GUI doesn't support SSL as of Nov 6, 2010
+MSF_OPTS="${MSF_OPTS} -S"
diff --git a/net-analyzer/metasploit/files/msfrpcd-4.3-initd b/net-analyzer/metasploit/files/msfrpcd-4.3-initd
new file mode 100644
index 000000000000..aa204bd961be
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfrpcd-4.3-initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/files/msfrpcd-4.3-initd,v 1.1 2012/05/02 04:42:58 patrick Exp $
+
+VERSION=4.2
+PIDFILE=/var/run/msfrpcd${VERSION}.pid
+
+start() {
+ ebegin "Starting msfrpcd${VERSION}"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/lib/metasploit${VERSION}/msfrpcd \
+ --pidfile ${PIDFILE} \
+ --make-pidfile -- -f ${MSF_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping msfrpcd${VERSION}"
+ start-stop-daemon --stop --quiet -s 9 --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/net-analyzer/metasploit/metasploit-4.3.0.ebuild b/net-analyzer/metasploit/metasploit-4.3.0.ebuild
new file mode 100644
index 000000000000..075aee0446d6
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-4.3.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-4.3.0.ebuild,v 1.1 2012/05/02 04:42:58 patrick Exp $
+
+EAPI="3"
+inherit eutils
+
+SRC_URI="http://updates.metasploit.com/data/releases/framework-${PV}.tar.bz2"
+
+DESCRIPTION="Advanced open-source framework for developing, testing, and using vulnerability exploit code"
+HOMEPAGE="http://www.metasploit.org/"
+
+LICENSE="BSD"
+SLOT="4.3"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui mysql postgres"
+
+# Note we use bundled gems (see data/msfweb/vendor/rails/) as upstream voted for
+# such solution, bug #247787
+RDEPEND="dev-lang/ruby
+ dev-ruby/rubygems
+ dev-ruby/msgpack
+ gui? ( virtual/jre )
+ mysql? ( dev-ruby/mysql-ruby
+ dev-ruby/activerecord[mysql] )
+ postgres? ( dev-ruby/ruby-postgres
+ dev-ruby/activerecord[postgres] )"
+DEPEND=""
+
+QA_PRESTRIPPED="
+ usr/lib/${PN}${SLOT}/data/msflinker_linux_x86.bin
+ usr/lib/${PN}${SLOT}/data/templates/template_armle_linux.bin
+ usr/lib/${PN}${SLOT}/data/templates/template_x86_linux.bin"
+
+QA_EXECSTACK="
+ usr/lib/${PN}${SLOT}/data/meterpreter/msflinker_linux_x86.bin"
+QA_WX_LOAD="
+ usr/lib/${PN}${SLOT}/data/templates/template_*_linux.bin"
+
+S=${WORKDIR}/msf3
+
+src_configure() {
+ # upstream makes weird tarbllz
+ find "${S}" -type d -name ".svn" -print0 | xargs -0 -n1 rm -R
+
+ rm "${S}"/msfupdate
+ chmod +x "${S}"/msf*
+
+ use gui || rm msfgui
+}
+
+src_install() {
+ # should be as simple as copying everything into the target...
+ dodir /usr/lib/${PN}${SLOT}
+ cp -R "${S}"/* "${D}"/usr/lib/${PN}${SLOT}
+ chown -R root:0 "${D}"
+
+ # do not remove LICENSE, bug #238137
+ dodir /usr/share/doc/${PF}
+ cp "${S}"/{README,HACKING} "${D}"/usr/share/doc/${PF}
+ dosym /usr/lib/${PN}${SLOT}/documentation /usr/share/doc/${PF}/documentation
+
+ dodir /usr/bin/
+ for file in msf*; do
+ dosym /usr/lib/${PN}${SLOT}/${file} /usr/bin/${file}${SLOT}
+ done
+
+ newinitd "${FILESDIR}"/msfrpcd-${SLOT}-initd msfrpcd${SLOT} || die
+ newconfd "${FILESDIR}"/msfrpcd-${SLOT}-conf msfrpcd${SLOT} || die
+
+ use gui && make_desktop_entry msfgui${SLOT} \
+ "Metasploit Framework" \
+ metasploit \
+ 'GNOME;System;Network;' &&
+ doicon "${FILESDIR}"/metasploit.xpm
+
+ # Avoid useless revdep-rebuild trigger #377617
+ dodir /etc/revdep-rebuild/
+ echo "SEARCH_DIRS_MASK=\"/usr/lib*/${PN}${SLOT}/data/john\"" > \
+ "${D}"/etc/revdep-rebuild/70-${PN}-${SLOT}
+}
+
+pkg_postinst() {
+ if use gui; then
+ elog "You will need to create a /usr/bin/msfrpcd symlink pointing to"
+ elog "the version of msfrpcd if you want to be able to start msfrpcd"
+ elog "from the java gui."
+ elog
+ elog "ln /usr/bin/msfrpcd${SLOT} /usr/bin/msfrpcd"
+ elog
+ fi
+}