summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-01-31 00:19:27 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-01-31 00:19:27 +0000
commit69db7cc2cccfa332698e623d728fcb576f1bfe18 (patch)
tree37a909c9262c82c5923a8aac3327f73c66047b42 /media-video/xine-ui
parentnautilus-cd-burner (diff)
downloadgentoo-2-69db7cc2cccfa332698e623d728fcb576f1bfe18.tar.gz
gentoo-2-69db7cc2cccfa332698e623d728fcb576f1bfe18.tar.bz2
gentoo-2-69db7cc2cccfa332698e623d728fcb576f1bfe18.zip
Version bump.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.181
-rw-r--r--media-video/xine-ui/xine-ui-0.9.18.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index e10fcda29533..0027211ce92a 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.24 2003/01/04 05:02:50 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.25 2003/01/31 00:19:24 agenkin Exp $
+
+*xine-ui-0.9.18 (30 Jan 2003)
+
+ 30 Jan 2003; Arcady Genkin <agenkin@gentoo.org> :
+ New version.
*xine-ui-0.9.17 (03 Jan 2003)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.18 b/media-video/xine-ui/files/digest-xine-ui-0.9.18
new file mode 100644
index 000000000000..f67bbab5a69b
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.18
@@ -0,0 +1 @@
+MD5 7aaabeb4cac95f66000741f970a17eca xine-ui-0.9.18.tar.gz 2465095
diff --git a/media-video/xine-ui/xine-ui-0.9.18.ebuild b/media-video/xine-ui/xine-ui-0.9.18.ebuild
new file mode 100644
index 000000000000..8e2a24487e83
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.18.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.18.ebuild,v 1.1 2003/01/31 00:19:24 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_alpha2
+ >=net-ftp/curl-7.10.2
+ app-misc/lirc
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}