summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-12 07:55:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-12 07:55:10 +0000
commit434d1aecc20535376b1b881aa857e7f7469abf2b (patch)
tree03c6f27c7412894dadb0a0a0da8deef3b47beca2 /media-sound/traverso
parent* Bug #135745 - Pull in >=sandbox-1.2.18.1-r2 to make sure users upgrade. (diff)
downloadgentoo-2-434d1aecc20535376b1b881aa857e7f7469abf2b.tar.gz
gentoo-2-434d1aecc20535376b1b881aa857e7f7469abf2b.tar.bz2
gentoo-2-434d1aecc20535376b1b881aa857e7f7469abf2b.zip
version bump, thanks a lot Remon for the notice
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'media-sound/traverso')
-rw-r--r--media-sound/traverso/ChangeLog9
-rw-r--r--media-sound/traverso/files/digest-traverso-0.42.03
-rw-r--r--media-sound/traverso/files/traverso-0.42.0-nojack.patch18
-rw-r--r--media-sound/traverso/files/traverso-0.42.0-strictaliasing.patch18
-rw-r--r--media-sound/traverso/traverso-0.42.0.ebuild57
5 files changed, 104 insertions, 1 deletions
diff --git a/media-sound/traverso/ChangeLog b/media-sound/traverso/ChangeLog
index 15f6db703aa4..ba7e9949fde8 100644
--- a/media-sound/traverso/ChangeLog
+++ b/media-sound/traverso/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/traverso
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/ChangeLog,v 1.12 2007/08/22 08:12:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/ChangeLog,v 1.13 2007/12/12 07:55:10 aballier Exp $
+
+*traverso-0.42.0 (12 Dec 2007)
+
+ 12 Dec 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/traverso-0.42.0-nojack.patch,
+ +files/traverso-0.42.0-strictaliasing.patch, +traverso-0.42.0.ebuild:
+ version bump, thanks a lot Remon for the notice
22 Aug 2007; Alexis Ballier <aballier@gentoo.org>
traverso-0.41.0-r1.ebuild:
diff --git a/media-sound/traverso/files/digest-traverso-0.42.0 b/media-sound/traverso/files/digest-traverso-0.42.0
new file mode 100644
index 000000000000..f20a8287d357
--- /dev/null
+++ b/media-sound/traverso/files/digest-traverso-0.42.0
@@ -0,0 +1,3 @@
+MD5 92a71c3001acacc649e9fb69dffd881d traverso-0.42.0.tar.gz 874836
+RMD160 83adf7686da7e192a253677c904f5786e39fafe9 traverso-0.42.0.tar.gz 874836
+SHA256 b91d1f536dcd3eb5f48a881c2b3da957e02f4f96a5573f6ca2d173347ed74be8 traverso-0.42.0.tar.gz 874836
diff --git a/media-sound/traverso/files/traverso-0.42.0-nojack.patch b/media-sound/traverso/files/traverso-0.42.0-nojack.patch
new file mode 100644
index 000000000000..581b48f93ae9
--- /dev/null
+++ b/media-sound/traverso/files/traverso-0.42.0-nojack.patch
@@ -0,0 +1,18 @@
+Index: traverso-0.42.0/src/traverso/CMakeLists.txt
+===================================================================
+--- traverso-0.42.0.orig/src/traverso/CMakeLists.txt
++++ traverso-0.42.0/src/traverso/CMakeLists.txt
+@@ -274,11 +274,11 @@ TARGET_LINK_LIBRARIES(traverso
+ )
+ ENDIF(HAVE_ALSA)
+
+-IF(HAVE_ALSA)
++IF(HAVE_JACK)
+ TARGET_LINK_LIBRARIES(traverso
+ ${JACK_LIB}
+ )
+-ENDIF(HAVE_ALSA)
++ENDIF(HAVE_JACK)
+
+ IF(USE_PCH)
+ ADD_DEPENDENCIES(traverso precompiled_headers)
diff --git a/media-sound/traverso/files/traverso-0.42.0-strictaliasing.patch b/media-sound/traverso/files/traverso-0.42.0-strictaliasing.patch
new file mode 100644
index 000000000000..70eae12dd76b
--- /dev/null
+++ b/media-sound/traverso/files/traverso-0.42.0-strictaliasing.patch
@@ -0,0 +1,18 @@
+Index: traverso-0.42.0/src/common/fpu.cc
+===================================================================
+--- traverso-0.42.0.orig/src/common/fpu.cc
++++ traverso-0.42.0/src/common/fpu.cc
+@@ -75,11 +75,12 @@ FPU::FPU ()
+ if (cpuflags & (1 << 24)) {
+
+ char* fxbuf = 0;
++ char** temp = &fxbuf;
+
+ #ifdef NO_POSIX_MEMALIGN
+ if ((fxbuf = (char *) malloc(512)) == 0)
+ #else
+- if (posix_memalign ((void**)&fxbuf, 16, 512))
++ if (posix_memalign ((void**)temp, 16, 512))
+ #endif
+ {
+ printf("FPU() ERROR: cannot allocate 16 byte aligned buffer for h/w feature detection");
diff --git a/media-sound/traverso/traverso-0.42.0.ebuild b/media-sound/traverso/traverso-0.42.0.ebuild
new file mode 100644
index 000000000000..5691bfa08591
--- /dev/null
+++ b/media-sound/traverso/traverso-0.42.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/traverso-0.42.0.ebuild,v 1.1 2007/12/12 07:55:10 aballier Exp $
+
+inherit eutils qt4 cmake-utils
+
+DESCRIPTION="Professional Audio Tools for GNU/Linux"
+HOMEPAGE="http://traverso-daw.org/"
+SRC_URI="http://traverso-daw.org/download/releases/current/${P}.tar.gz"
+
+IUSE="alsa debug jack lame lv2 mad opengl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="$(qt4_min_version 4.3.1)
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ >=dev-libs/glib-2.8
+ >=media-libs/libsndfile-1.0.12
+ media-libs/libsamplerate
+ >=sci-libs/fftw-3
+ >=media-sound/wavpack-4.40.0
+ >=media-libs/libvorbis-1.1.2
+ >=media-libs/flac-1.1.2
+ lv2? ( media-libs/slv2 )
+ mad? ( media-libs/libmad )
+ lame? ( media-sound/lame )"
+
+pkg_setup() {
+ if use opengl && ! built_with_use =x11-libs/qt-4* opengl; then
+ eerror "You need to build qt4 with opengl support to have it in ${PN}"
+ die "Enabling opengl for traverso requires qt4 to be built with opengl support"
+ fi
+}
+
+mycmakeargs="$(cmake-utils_use_want jack JACK) $(cmake-utils_use_want alsa ALSA) \
+ $(cmake-utils_use_want lv2 LV2) -DUSE_SYSTEM_SLV2_LIBRARY=ON \
+ $(cmake-utils_use_want mad MP3_DECODE) $(cmake-utils_use_want lame MP3_ENCODE) \
+ $(cmake-utils_use_want opengl OPENGL) $(cmake-utils_use_want debug TRAVERSO_DEBUG)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-nojack.patch"
+ epatch "${FILESDIR}/${P}-strictaliasing.patch"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog README resources/help.text
+ doicon resources/freedesktop/icons/128x128/apps/traverso.png
+ domenu resources/traverso.desktop
+ insinto /usr/share/${PN}
+ doins -r resources/themes
+}