summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-03-09 11:08:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-03-09 11:08:09 +0000
commit63208bad28b9023be50ea8fab52616d81138f4bb (patch)
tree092bf20ad0137d7b550bc01201054294ff073078 /media-libs/x264
parentalpha stable wrt bug #495430; Drop old. (diff)
downloadgentoo-2-63208bad28b9023be50ea8fab52616d81138f4bb.tar.gz
gentoo-2-63208bad28b9023be50ea8fab52616d81138f4bb.tar.bz2
gentoo-2-63208bad28b9023be50ea8fab52616d81138f4bb.zip
bump a new snapshot
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-0.0.20140308.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 97e765e21e79..057bfff98232 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.102 2014/03/09 09:56:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.103 2014/03/09 11:08:09 aballier Exp $
+
+*x264-0.0.20140308 (09 Mar 2014)
+
+ 09 Mar 2014; Alexis Ballier <aballier@gentoo.org> +x264-0.0.20140308.ebuild:
+ bump a new snapshot
09 Mar 2014; Alexis Ballier <aballier@gentoo.org> x264-9999.ebuild:
current git uses .so.142: update subslot
diff --git a/media-libs/x264/x264-0.0.20140308.ebuild b/media-libs/x264/x264-0.0.20140308.ebuild
new file mode 100644
index 000000000000..e7be06dc13fe
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20140308.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20140308.ebuild,v 1.1 2014/03/09 11:08:09 aballier Exp $
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+else
+ inherit versionator
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+SONAME="142"
+SLOT="0/${SONAME}"
+
+LICENSE="GPL-2"
+IUSE="10bit +interlaced opencl pic static-libs sse +threads"
+
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+ opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( virtual/opencl[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r7
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+DOCS="AUTHORS doc/*.txt"
+
+src_prepare() {
+ # Initial support for x32 ABI, bug #420241
+ # Avoid messing too much with CFLAGS.
+ epatch "${FILESDIR}"/x264-cflags.patch
+}
+
+multilib_src_configure() {
+ tc-export CC
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && use pic || [[ ${ABI} == "x32" ]]; then
+ asm_conf=" --disable-asm"
+ fi
+
+ # Upstream uses this, see the cflags patch
+ use sse && append-flags "-msse" "-mfpmath=sse"
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ $(usex 10bit "--bit-depth=10" "") \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex opencl "" "--disable-opencl") \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}