summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-03-08 19:33:49 +0000
committerAnant Narayanan <anant@gentoo.org>2007-03-08 19:33:49 +0000
commit8e6f50bdb46adc681b136a77530d24f4b80eb6a8 (patch)
tree724441448877c5f62ba5f2acbeae7474ad405a0c /media-libs/jpgalleg
parentStable on sparc wrt #169782 (diff)
downloadgentoo-2-8e6f50bdb46adc681b136a77530d24f4b80eb6a8.tar.gz
gentoo-2-8e6f50bdb46adc681b136a77530d24f4b80eb6a8.tar.bz2
gentoo-2-8e6f50bdb46adc681b136a77530d24f4b80eb6a8.zip
vBump to 2.5, thanks to Ryan Patterson, bug #155083
(Portage version: 2.1.2.1)
Diffstat (limited to 'media-libs/jpgalleg')
-rw-r--r--media-libs/jpgalleg/ChangeLog9
-rw-r--r--media-libs/jpgalleg/files/digest-jpgalleg-2.53
-rw-r--r--media-libs/jpgalleg/jpgalleg-2.5.ebuild41
3 files changed, 51 insertions, 2 deletions
diff --git a/media-libs/jpgalleg/ChangeLog b/media-libs/jpgalleg/ChangeLog
index 448e56f9e2bd..43b5bcfc48a8 100644
--- a/media-libs/jpgalleg/ChangeLog
+++ b/media-libs/jpgalleg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/jpgalleg
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/ChangeLog,v 1.5 2004/09/30 00:47:36 swegener Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/ChangeLog,v 1.6 2007/03/08 19:33:49 anant Exp $
+
+*jpgalleg-2.5 (08 Mar 2007)
+
+ 08 Mar 2007; <anant@gentoo.org> +jpgalleg-2.5.ebuild:
+ vBump to 2.5, thanks to Ryan Patterson, bug #155083
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> jpgalleg-1.1-r1.ebuild:
Add inherit eutils
diff --git a/media-libs/jpgalleg/files/digest-jpgalleg-2.5 b/media-libs/jpgalleg/files/digest-jpgalleg-2.5
new file mode 100644
index 000000000000..7f56765324bf
--- /dev/null
+++ b/media-libs/jpgalleg/files/digest-jpgalleg-2.5
@@ -0,0 +1,3 @@
+MD5 4bdd12fc3c1afb06f4ec23b4cb200559 jpgalleg-2.5.tar.gz 232648
+RMD160 b840d1e6c39bbe0ba3445ac31ced94e479ad5f81 jpgalleg-2.5.tar.gz 232648
+SHA256 5946b58f6da1a2f5ce907b25c8550d4db7f8aaf2614203278a3a1becc0daffcf jpgalleg-2.5.tar.gz 232648
diff --git a/media-libs/jpgalleg/jpgalleg-2.5.ebuild b/media-libs/jpgalleg/jpgalleg-2.5.ebuild
new file mode 100644
index 000000000000..63e83bdaa54f
--- /dev/null
+++ b/media-libs/jpgalleg/jpgalleg-2.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpgalleg/jpgalleg-2.5.ebuild,v 1.1 2007/03/08 19:33:49 anant Exp $
+
+inherit eutils
+
+DESCRIPTION="The jpeg loading routines are able to load almost any JPG image
+file with Allegro."
+HOMEPAGE="http://www.ecplusplus.com/index.php?page=projects&pid=1"
+SRC_URI="http://www.ecplusplus.com/files/${PN}-${PV}.tar.gz"
+
+LICENSE="ZLIB"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/allegro-4.0.0"
+S="${WORKDIR}/${PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./fix.sh unix --quick
+ emake || die "emake failed"
+}
+
+src_install() {
+ mkdir ${D}usr
+ mkdir ${D}usr/include
+ mkdir ${D}usr/lib
+
+ emake install INSTALL_BASE_PATH="${D}usr" || die "emake install failed"
+
+ dodoc readme.txt
+
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*
+}