summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-04-29 16:57:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-04-29 16:57:19 +0000
commitcb662848021d157c06f3a1e2d5a81304fa9948e6 (patch)
treece38908a29e390f44a0841873c6186df62f45e7a /media-gfx/dispcalgui
parentmarked ~x86 per bug 395157 (diff)
downloadgentoo-2-cb662848021d157c06f3a1e2d5a81304fa9948e6.tar.gz
gentoo-2-cb662848021d157c06f3a1e2d5a81304fa9948e6.tar.bz2
gentoo-2-cb662848021d157c06f3a1e2d5a81304fa9948e6.zip
Version bump. Thanks to Marios Andreopoulos <opensource@andmarios.com>. Fixes bug #413539
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dispcalgui')
-rw-r--r--media-gfx/dispcalgui/ChangeLog8
-rw-r--r--media-gfx/dispcalgui/dispcalgui-0.9.9.1.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/media-gfx/dispcalgui/ChangeLog b/media-gfx/dispcalgui/ChangeLog
index aafc09b62a17..5ef9c3260dd1 100644
--- a/media-gfx/dispcalgui/ChangeLog
+++ b/media-gfx/dispcalgui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/dispcalgui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.10 2012/03/01 22:02:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.11 2012/04/29 16:57:19 hwoarang Exp $
+
+*dispcalgui-0.9.9.1 (29 Apr 2012)
+
+ 29 Apr 2012; Markos Chandras <hwoarang@gentoo.org> +dispcalgui-0.9.9.1.ebuild:
+ Version bump. Thanks to Marios Andreopoulos <opensource@andmarios.com>. Fixes
+ bug #413539
01 Mar 2012; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
add proxy-maintainers as herd
diff --git a/media-gfx/dispcalgui/dispcalgui-0.9.9.1.ebuild b/media-gfx/dispcalgui/dispcalgui-0.9.9.1.ebuild
new file mode 100644
index 000000000000..9fb77b9e4f64
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-0.9.9.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/dispcalgui-0.9.9.1.ebuild,v 1.1 2012/04/29 16:57:19 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils fdo-mime
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ >=dev-python/wxpython-2.8.10.1
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Set udev rules to install at /lib/udev/rules.d
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "/etc/udev/rules.d" *); do
+ sed -e 's|/etc/udev/rules\.d|/lib/udev/rules\.d|g' -i "${offendingFile}" || \
+ die "setting udev rules' destination directory failed"
+ done
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}