summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2007-03-18 05:08:41 +0000
committerMarius Mauch <genone@gentoo.org>2007-03-18 05:08:41 +0000
commitfdbf2675d76451e93464e4b68958126c91168731 (patch)
tree84b06832bfce1da218ca994beaf04200ee9732a9 /mail-mta
parentReplacing einfo with elog (diff)
downloadgentoo-2-fdbf2675d76451e93464e4b68958126c91168731.tar.gz
gentoo-2-fdbf2675d76451e93464e4b68958126c91168731.tar.bz2
gentoo-2-fdbf2675d76451e93464e4b68958126c91168731.zip
Replacing einfo with elog
(Portage version: 2.1.2.2)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/courier/ChangeLog9
-rw-r--r--mail-mta/courier/courier-0.48.1-r1.ebuild8
-rw-r--r--mail-mta/courier/courier-0.48.1.ebuild8
-rw-r--r--mail-mta/courier/courier-0.48.2.20050224.ebuild12
-rw-r--r--mail-mta/courier/courier-0.49.0.20050405.ebuild12
-rw-r--r--mail-mta/courier/courier-0.49.0.ebuild12
-rw-r--r--mail-mta/courier/courier-0.50.0.ebuild12
-rw-r--r--mail-mta/courier/courier-0.50.1-r1.ebuild18
-rw-r--r--mail-mta/courier/courier-0.50.1.ebuild12
-rw-r--r--mail-mta/courier/courier-0.52.2.ebuild18
-rw-r--r--mail-mta/courier/courier-0.53.2.ebuild18
11 files changed, 73 insertions, 66 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 7d14babda43b..c861f6888618 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.86 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.87 2007/03/18 05:08:41 genone Exp $
+
+ 18 Mar 2007; Marius Mauch <genone@gentoo.org> courier-0.48.1.ebuild,
+ courier-0.48.1-r1.ebuild, courier-0.48.2.20050224.ebuild,
+ courier-0.49.0.ebuild, courier-0.49.0.20050405.ebuild,
+ courier-0.50.0.ebuild, courier-0.50.1.ebuild, courier-0.50.1-r1.ebuild,
+ courier-0.52.2.ebuild, courier-0.53.2.ebuild:
+ Replacing einfo with elog
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
courier-0.48.2.20050224.ebuild, courier-0.49.0.ebuild,
diff --git a/mail-mta/courier/courier-0.48.1-r1.ebuild b/mail-mta/courier/courier-0.48.1-r1.ebuild
index cbfc8fdc16f1..a06e05551230 100644
--- a/mail-mta/courier/courier-0.48.1-r1.ebuild
+++ b/mail-mta/courier/courier-0.48.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.1-r1.ebuild,v 1.8 2006/11/23 20:24:09 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.1-r1.ebuild,v 1.9 2007/03/18 05:08:41 genone Exp $
inherit eutils
@@ -100,7 +100,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${key}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -110,7 +110,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
diff --git a/mail-mta/courier/courier-0.48.1.ebuild b/mail-mta/courier/courier-0.48.1.ebuild
index d92c628335f1..a62730aa6ad1 100644
--- a/mail-mta/courier/courier-0.48.1.ebuild
+++ b/mail-mta/courier/courier-0.48.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.1.ebuild,v 1.7 2006/11/23 20:24:09 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.1.ebuild,v 1.8 2007/03/18 05:08:41 genone Exp $
inherit eutils
@@ -99,7 +99,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${key}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -109,7 +109,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
diff --git a/mail-mta/courier/courier-0.48.2.20050224.ebuild b/mail-mta/courier/courier-0.48.2.20050224.ebuild
index 8ccdf61dd1f8..43ebf0cefdd1 100644
--- a/mail-mta/courier/courier-0.48.2.20050224.ebuild
+++ b/mail-mta/courier/courier-0.48.2.20050224.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050224.ebuild,v 1.7 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050224.ebuild,v 1.8 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -49,8 +49,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -121,7 +121,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -131,7 +131,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -243,7 +243,7 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
}
diff --git a/mail-mta/courier/courier-0.49.0.20050405.ebuild b/mail-mta/courier/courier-0.49.0.20050405.ebuild
index 23d59594ac40..ff640edef50d 100644
--- a/mail-mta/courier/courier-0.49.0.20050405.ebuild
+++ b/mail-mta/courier/courier-0.49.0.20050405.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.49.0.20050405.ebuild,v 1.4 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.49.0.20050405.ebuild,v 1.5 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -49,8 +49,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -121,7 +121,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -131,7 +131,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -243,7 +243,7 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
}
diff --git a/mail-mta/courier/courier-0.49.0.ebuild b/mail-mta/courier/courier-0.49.0.ebuild
index f36dd3e6fb5f..4be5c8513254 100644
--- a/mail-mta/courier/courier-0.49.0.ebuild
+++ b/mail-mta/courier/courier-0.49.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.49.0.ebuild,v 1.5 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.49.0.ebuild,v 1.6 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -49,8 +49,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -121,7 +121,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -131,7 +131,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -243,7 +243,7 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
}
diff --git a/mail-mta/courier/courier-0.50.0.ebuild b/mail-mta/courier/courier-0.50.0.ebuild
index 1d3090aa2d6d..38cb7ae50fed 100644
--- a/mail-mta/courier/courier-0.50.0.ebuild
+++ b/mail-mta/courier/courier-0.50.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.0.ebuild,v 1.3 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.0.ebuild,v 1.4 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -49,8 +49,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -121,7 +121,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -131,7 +131,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -243,7 +243,7 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
}
diff --git a/mail-mta/courier/courier-0.50.1-r1.ebuild b/mail-mta/courier/courier-0.50.1-r1.ebuild
index f1dfced5d4ee..e87bfdd94536 100644
--- a/mail-mta/courier/courier-0.50.1-r1.ebuild
+++ b/mail-mta/courier/courier-0.50.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.1-r1.ebuild,v 1.4 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.1-r1.ebuild,v 1.5 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -51,8 +51,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -123,7 +123,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -133,7 +133,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -264,13 +264,13 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
# fix for bug #99334
- einfo "Courier's sendmail is not suid by default, therefore non-root users can't send"
- einfo "mail using sendmail. If you need this to work, you should set sendmail suid."
- einfo "See also: http://www.courier-mta.org/install.html#suid"
+ elog "Courier's sendmail is not suid by default, therefore non-root users can't send"
+ elog "mail using sendmail. If you need this to work, you should set sendmail suid."
+ elog "See also: http://www.courier-mta.org/install.html#suid"
}
pkg_config() {
diff --git a/mail-mta/courier/courier-0.50.1.ebuild b/mail-mta/courier/courier-0.50.1.ebuild
index 0304efc836f1..f666a8fac894 100644
--- a/mail-mta/courier/courier-0.50.1.ebuild
+++ b/mail-mta/courier/courier-0.50.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.1.ebuild,v 1.3 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.50.1.ebuild,v 1.4 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -49,8 +49,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -121,7 +121,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -131,7 +131,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -260,7 +260,7 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
}
diff --git a/mail-mta/courier/courier-0.52.2.ebuild b/mail-mta/courier/courier-0.52.2.ebuild
index 45bc8fb98bf0..c2de4c9ad659 100644
--- a/mail-mta/courier/courier-0.52.2.ebuild
+++ b/mail-mta/courier/courier-0.52.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.52.2.ebuild,v 1.6 2007/01/05 07:58:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.52.2.ebuild,v 1.7 2007/03/18 05:08:41 genone Exp $
inherit eutils flag-o-matic
@@ -51,8 +51,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -123,7 +123,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -133,7 +133,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -264,13 +264,13 @@ src_install() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
# fix for bug #99334
- einfo "Courier's sendmail is not suid by default, therefore non-root users can't send"
- einfo "mail using sendmail. If you need this to work, you should set sendmail suid."
- einfo "See also: http://www.courier-mta.org/install.html#suid"
+ elog "Courier's sendmail is not suid by default, therefore non-root users can't send"
+ elog "mail using sendmail. If you need this to work, you should set sendmail suid."
+ elog "See also: http://www.courier-mta.org/install.html#suid"
}
pkg_config() {
diff --git a/mail-mta/courier/courier-0.53.2.ebuild b/mail-mta/courier/courier-0.53.2.ebuild
index 23df17289e8d..dd750486d359 100644
--- a/mail-mta/courier/courier-0.53.2.ebuild
+++ b/mail-mta/courier/courier-0.53.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.13 2007/01/04 15:01:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.14 2007/03/18 05:08:41 genone Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -54,8 +54,8 @@ filter-flags '-fomit-frame-pointer'
src_unpack() {
use fam || (
ewarn "File Alteration Monitor (FAM) is disabled"
- einfo "courier-imap will fall back to 60 second polls."
- einfo 'add "fam" to your USE flags to build as usual'
+ ewarn "courier-imap will fall back to 60 second polls."
+ ewarn 'add "fam" to your USE flags to build as usual'
ebeep 4
epause 4 )
unpack ${A}
@@ -123,7 +123,7 @@ etc_courier() {
etc_courier_chg() {
file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
[ -z "${section}" ] && section="${2}"
- grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
@@ -133,7 +133,7 @@ set_maildir() {
newmaildir='.maildir'
for f in ${files} ; do
grep -q "${origmaildir}" "${f}" && \
- einfo "Changing ${origmaildir} in ${f} to ${newmaildir}"
+ elog "Changing ${origmaildir} in ${f} to ${newmaildir}"
sed -i -e"/^[^\#]/ s/${origmaildir}/${newmaildir}/g" ${f}
done
}
@@ -278,13 +278,13 @@ src_test() {
}
pkg_postinst() {
- use fam && einfo "fam daemon is needed for courier-imapd" \
+ use fam && elog "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"
# fix for bug #99334
- einfo "Courier's sendmail is not suid by default, therefore non-root users can't send"
- einfo "mail using sendmail. If you need this to work, you should set sendmail suid."
- einfo "See also: http://www.courier-mta.org/install.html#suid"
+ elog "Courier's sendmail is not suid by default, therefore non-root users can't send"
+ elog "mail using sendmail. If you need this to work, you should set sendmail suid."
+ elog "See also: http://www.courier-mta.org/install.html#suid"
}
pkg_config() {