summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-02 12:28:35 +0000
committerJohannes Huber <johu@gentoo.org>2015-08-02 12:28:35 +0000
commitbcc5f5e0248f3d53ad36fd3d5f8f21a0aa0a5f25 (patch)
tree6ae4d7e02ea481ca275ac52cbddac4ad08552216 /kde-plasma
parentVersion bump. I was going to raise the ffmpeg/libav minimum versions (diff)
downloadgentoo-2-bcc5f5e0248f3d53ad36fd3d5f8f21a0aa0a5f25.tar.gz
gentoo-2-bcc5f5e0248f3d53ad36fd3d5f8f21a0aa0a5f25.tar.bz2
gentoo-2-bcc5f5e0248f3d53ad36fd3d5f8f21a0aa0a5f25.zip
Add patch to remove bogus deps by Andreas Sturmlechner <andreas.sturmlechner@gmail.com>, bug #555770.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xFDF4F788)
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-sdk/ChangeLog7
-rw-r--r--kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch11
-rw-r--r--kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild4
3 files changed, 20 insertions, 2 deletions
diff --git a/kde-plasma/plasma-sdk/ChangeLog b/kde-plasma/plasma-sdk/ChangeLog
index 2cce1b244654..a02f7eb6d1b4 100644
--- a/kde-plasma/plasma-sdk/ChangeLog
+++ b/kde-plasma/plasma-sdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-plasma/plasma-sdk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-plasma/plasma-sdk/ChangeLog,v 1.4 2015/07/09 20:49:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/plasma-sdk/ChangeLog,v 1.5 2015/08/02 12:28:35 johu Exp $
+
+ 02 Aug 2015; Johannes Huber <johu@gentoo.org>
+ +files/plasma-sdk-5.3.2-remove-qtwebkit.patch, plasma-sdk-5.3.2.ebuild:
+ Add patch to remove bogus deps by Andreas Sturmlechner
+ <andreas.sturmlechner@gmail.com>, bug #555770.
09 Jul 2015; Johannes Huber <johu@gentoo.org> -plasma-sdk-5.3.1.ebuild:
Remove KDE Plasma 5.3.1
diff --git a/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch b/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch
new file mode 100644
index 000000000000..6a5c8b0e9001
--- /dev/null
+++ b/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2015-07-18 18:21:24.686994466 +0200
++++ b/CMakeLists.txt 2015-07-18 18:21:51.772993658 +0200
+@@ -24,7 +24,7 @@
+ # where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
+
+-find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core DBus Gui Qml Quick Svg WebKit WebKitWidgets Widgets Xml)
++find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core DBus Gui Qml Quick Svg Widgets Xml)
+
+ find_package(Qt5Test ${QT_MIN_VERSION} CONFIG QUIET)
+ set_package_properties(Qt5Test PROPERTIES
diff --git a/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild b/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild
index f6be475dfd22..991a1a5aea5c 100644
--- a/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild
+++ b/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild,v 1.2 2015/07/06 15:35:07 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild,v 1.3 2015/08/02 12:28:35 johu Exp $
EAPI=5
@@ -35,3 +35,5 @@ DEPEND="
RDEPEND="${DEPEND}
!dev-util/plasmate
"
+
+PATCHES=( "${FILESDIR}/${P}-remove-qtwebkit.patch" )