summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 19:25:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 19:25:44 +0000
commit22369dc4fdd0fc3e83afba20c69a4506c982c227 (patch)
tree671692e580a883f0a064d892f12167d978e94f50 /kde-base/kaddressbook
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-22369dc4fdd0fc3e83afba20c69a4506c982c227.tar.gz
gentoo-2-22369dc4fdd0fc3e83afba20c69a4506c982c227.tar.bz2
gentoo-2-22369dc4fdd0fc3e83afba20c69a4506c982c227.zip
Bump to 3.5.6 (prerelease).
(Portage version: 2.1.2)
Diffstat (limited to 'kde-base/kaddressbook')
-rw-r--r--kde-base/kaddressbook/ChangeLog10
-rw-r--r--kde-base/kaddressbook/files/digest-kaddressbook-3.5.63
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5.6.ebuild55
3 files changed, 66 insertions, 2 deletions
diff --git a/kde-base/kaddressbook/ChangeLog b/kde-base/kaddressbook/ChangeLog
index 371d19301f9b..77d841f72757 100644
--- a/kde-base/kaddressbook/ChangeLog
+++ b/kde-base/kaddressbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kaddressbook
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.67 2006/12/11 14:17:50 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.68 2007/01/16 19:25:44 flameeyes Exp $
+
+*kaddressbook-3.5.6 (16 Jan 2007)
+
+ 16 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +kaddressbook-3.5.6.ebuild:
+ Bump to 3.5.6 (prerelease).
11 Dec 2006; <kloeri@gentoo.org> ChangeLog:
Stable on ia64.
diff --git a/kde-base/kaddressbook/files/digest-kaddressbook-3.5.6 b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.6
new file mode 100644
index 000000000000..48727dabc040
--- /dev/null
+++ b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.6
@@ -0,0 +1,3 @@
+MD5 06744c36252414c809d6df46058f1bfd kdepim-3.5.6.tar.bz2 13645180
+RMD160 c68a01d9ce29d3ad41e18a79f39a961d2ef2383a kdepim-3.5.6.tar.bz2 13645180
+SHA256 018027c75944ef9ea471c1422269832fc890f004c2684144859c301c6d7d5bf6 kdepim-3.5.6.tar.bz2 13645180
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.6.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.6.ebuild
new file mode 100644
index 000000000000..4126d457dff0
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.5.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.6.ebuild,v 1.1 2007/01/16 19:25:44 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnokii"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+gnokii? ( app-mobilephone/gnokii )"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ myconf="$myconf $(use_with gnokii)"
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libkcal/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile "make"
+}